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Working with the Northwind Sample Database 
 
When you have completed this learning module you will have seen how to: 

 Install Northwind 
 Check for Northwind 
 
 

Installing the Northwind Database 
 

About Northwind 
 Northwind is a sample database that ships with Access 2002.  It contains 

product and sales data for the fictitious company Northwind Traders. 
 It is recommended that Northwind be installed to follow the lessons in this 

manual. 
 

Checking for Northwind 
 Click the Search button on the database toolbar: 

 

 
 

 In the Search text box, type Northwind. 
 Click Search. 
 If Northwind.mdb appears in the Search Results, click on the file to open 

it and proceed to the next chapter. 
 If Northwind is not found in the Search Results it will need to be installed. 
 

Installing Northwind 
 Insert the Microsoft Office XP CD-ROM in the CD-ROM drive. 
 Double-click Setup. 

 
Note:  If your computer has autorun enabled, you will be presented directly 
with the Microsoft Office XP setup screen. 
 

 Select Add or Remove Features. 
 Click Next. 
 Under Features to Install, select the Microsoft Access for Windows 

subtree. 
 

 Under Sample Databases, select Run all from My Computer: 
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 Click Update. 
 Once the installer completes, click OK to finish. 

 
Note:  Once the Northwind database is installed, search for it again and 
open it. 

 
 

Review Questions 
 
How would you: 

 Install Northwind? 
 Check for Northwind? 
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Designing Tables in Access 2002 
 
When you have completed this learning module you will have seen how to: 

 Set a Primary Key 
 Remove Non-related Data 
 Remove Redundant Data 
 Remove Repeating Data 
 Set Required Values in Columns 
 Use the Relationship Tool 
 Identify a Related Table 
 Create Join Types 
 Enforce Referential Integrity 
 Work with Cascading Updates and Deletes 
 Create a Single-Field Index 
 Create a Multiple-Field Index 
 Set the Index Sort Order 
 Set Index Properties 
 Delete Indexes 
 Choose Appropriate Data Types 
 Set Column Data Types 
 Format Data Types 
 Convert Between Data Types 
 
 

Normalizing Data 
 

Setting a Primary Key 
 A primary key is a field that uniquely identifies a row in a table and can be 

based on any alphanumeric value. 
 
To set a primary key: 

 Open a table in Design view. 
 Right-click on the field you want to set as the primary key. 
 From the pop-up menu, select Primary Key: 
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Note:  You must save the table to save the primary key. 

 

Removing Non-related Data 
 Part of the normalization process is to remove non-related values.  For 

example, in the Employees table, it is incorrect to include customer data.  
That would result in a mixing of different areas of subject matter.  Customer 
data should be stored in a separate table. 

 

Removing Redundant Data 
 Another part of the normalization process is to remove redundant values.  

A redundant value is one that appears multiple times in the same table.  For 
example, in the Suppliers table it is incorrect to repeat all supplier data for 
each product a supplier sells.  It is more efficient and manageable to create 
supplier data once and then relate supplier data to product data in the 
Products table.  By doing this, supplier data only needs to be updated once 
in the Suppliers table rather than multiple times in the Products table. 

 

Removing Repeating Data 
 An additional part of the normalization process is to remove repeating 

values.  Repeating values are similar values that appear across multiple 
columns of a table.  For example, it is incorrect to create a new column for 
each product sold in the Orders table.  Instead, it is more efficient and 
manageable to relate order data by Order ID to another table called Order 
Details.  Each row in Order Details represents a line item on an order.  

 

Setting Required Values in Columns 
 Yet another part of the normalization process is to ensure that all fields 

have values.  A well-designed table will not allow null values.  A null value 
means that a value is unknown.  This is different from a blank or zero-length 
value. 

 
To set required fields: 

 Open a table in Design view. 
 Select the Data Type pane for the desired field. 
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 Find the General tab in the lower-left portion of the design window. 
 In the General tab select the Required field. 
 Choose Yes to make the field required:  

 

 
 
Note:  You must save the table to save the field change. 

 
 

Establishing Relationships 
 

Using the Relationship Tool 
 The Relationship tool manages joins between related fields in different 

tables. 
 
To delete a relationship: 

 Click the Relationships button on the Database toolbar: 
 

 
 

 Right-click on the relationship between two tables. 
 From the pop-up menu, select Delete: 

 

 
 

 Click Yes when prompted to delete the relationship. 
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To create a relationship: 

 Click the Relationships button on the Database toolbar. 
 Drag a field from one table to another table: 

 

 
 

 This opens the Edit Relationships dialog box. 
 Click Create: 

 

 
 

Identifying a Related Table 
 Tables that are related will have fields that are common between them.  For 

example, Shippers and Orders are related by the ShipperID and ShipVia 
fields respectively.  It is easier to identify relationships if the field names 
are the same.  Related fields should have the same data type.  For example, 
EmployeeID is defined as a long integer in both the Orders and 
Employees tables. 
 
Note:  Data types are discussed in more detail later in this training manual. 

 

Creating Join Types 
 There are three join types in Access: one-to-one, one-to-many, and many-to-

many.  
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 A one-to-one relationship has only one matching row in each related table.  
One-to-one relationships are not common.  An example would be a table 
with many columns divided into multiple tables that relate to one master key 
value. 

 A one-to-many relationship has a row in one table that matches many rows 
in a related table.  This is the most common type of relationship.  An example 
is the relationship between the Customers and Orders table.  This 
relationship is described as one customer having many orders and each order 
belonging to only one customer. 

 A many-to-many relationship has many rows in one table that match many 
rows in a related table.  This is a special relationship that involves a third 
table called a junction table.  An example is the relationship between 
Orders and Products.  These two tables are joined by a junction table called 
Order Details.  This relationship is described as many orders having many 
products and many products belonging to many orders. 

 
To create a join type: 

 Right-click on the relationship between two tables. 
 From the pop-up menu, select Edit Relationship: 

 

 
 

 This opens the Edit Relationships dialog box. 
 Click Join Type: 

 

 
 

 This opens the Join Properties dialog box. 
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 Select the desired relationship type: 
 

 
 

 Click OK. 
 

Enforcing Referential Integrity 
 Referential integrity ensures that related records between tables are valid. 
 
To set referential integrity: 

 Right-click on the join between two tables. 
 From the pop-up menu, select Edit Relationship.  This opens the Edit 

Relationships dialog box. 
 Check the Enforce Referential Integrity box: 

 

 
 

 Click OK. 
 

Working with Cascading Updates and Deletes 
 Cascading allows for updates or deletes of related records without violating 

referential integrity.  Use cascading when there is a need to propagate 
foreign key data changes.  For example, if there is an update of 
EmployeeID in the Employees table, then all related records in Orders 
should also be updated with the new EmployeeID so that an employee's 
sales history is not lost.  Cascading will make this change automatic. 

 
To set cascading options: 

 Right-click on the join between two tables. 

SAMPLE



Microsoft Access XP - Intermediate Level Manual - Page 14 

FOR USE AT THE LICENSED SITE(S) ONLY 
 Cheltenham Courseware Pty. Ltd. 1995-2010 www.cheltenhamcourseware.com 

 From the pop-up menu, select Edit Relationship.  This opens the Edit 
Relationships dialog box. 

 Check the Cascade Update Related Fields and/or Cascade Delete 
Related Fields box: 
 

 
 

 Click OK. 
 
Note:  The Enforce Referential Integrity box must be checked to set 
cascading options. 

 
 

Working with Indexes 
 

Creating a Single-Field Index 
 An index is used to improve the performance of data searches.  A single-

field index is defined only on one field.  Use a single-field index on a field 
that will participate in a relationship.  For example, CategoryID in the 
Products table is defined as a single-field index and is related to the 
CategoryID field in the Categories table. 

 
To create a single-field index: 

 Open a table in Design view. 
 Click the Indexes button on the Table Design toolbar: 

 

 
 
OR from the main menu, select View > Indexes: 
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 This opens the Indexes design grid. 
 Type a name in the Index Name column. 
 Select a desired field from the drop-down menu in the Field Name column: 

 

 
 

 Click the Close button on the Indexes title bar. 
 
Note:  The default Sort Order is defined as Ascending.  Setting the sort 
order is discussed later in this chapter. 

 

Creating a Multiple-Field Index 
 A multiple-field index is defined on two or more fields.  Use a multiple-

field index on fields that will be used in complex queries. 
 
To create a multiple-field index: 

 Open a table in Design view. 
 Click the Indexes button on the Table Design toolbar 

 
OR from the main menu, select View > Indexes. 
 

 This opens the Indexes design grid. 
 Type a name in the Index Name column. 
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 Select multiple fields from the drop-down menu in the Field Name column: 
 

 
 

 Click the Close button on the Indexes title bar. 
 
Note:  Each multiple-field index can use up to 10 fields. 

 

Setting the Index Sort Order 
 The index sort order improves the performance of queries that use sorting 

functionality.  For example, writing a query that sorts CompanyName in 
descending order from the Customers table would benefit from a 
descending sort order index. 

 
To set the index sort order: 

 Open a table in Design view. 
 Click the Indexes button on the Table Design toolbar 

OR from the main menu, select View > Indexes. 
 

 This opens the Indexes design grid. 
 Click the drop-down menu in the Sort Order column. 
 Select Descending to change the sort order. 

 

 
 

 Click the Close button on the Indexes title bar. 
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Setting Index Properties 
 The behavior of an index can be controlled by setting the properties on the 

index.  The available properties are Primary, Unique, and Ignore Nulls.  
The Primary property allows for an additional method of setting the primary 
key for a table.  The Unique property determines if duplicate values are 
allowed in the index.  The Ignore Nulls determines if unknown values are 
included in the index. 

 
To set index properties: 

 Open a table in Design view. 
 Click the Indexes button on the Table Design toolbar 

OR from the main menu, select View > Indexes. 
 

 This opens the Indexes design grid. 
 Select an index. 
 Select a Primary property from the drop-down menu in the Index 

Properties section. 
 Select a Unique property from the drop-down menu in the Index 

Properties section. 
 Select an Ignore Nulls property from the drop-down menu in the Index 

Properties section: 
 

 
 

 Click the Close button on the Indexes title bar. 
 
Note:  Changing the index properties on an existing index can cause 
unexpected changes in the index behavior.  The Primary property cannot be 
set on another field if the original primary key is part of a relationship. 

 

Deleting Indexes 
 Open a table in Design view. 
 Click the Indexes button on the Table Design toolbar 

OR from the main menu, select View > Indexes. 
 

 This opens the Indexes design grid. 
 Right-click on an Index Name. 
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 From the pop-up menu, select Delete Rows: 
 

 
 

 Click the Close button on the Indexes title bar. 
 
 

Working with Data Types 
 

Choosing Appropriate Data Types 
 Determining which data type to use for a field is a very important step in 

designing a table.  The available data types are Text, Memo, Number, 
Date/Time, Currency, AutoNumber, Yes/No, OLE Object, and 
Hyperlink.  The following are some important considerations when deciding 
which data types to use: 
 
Storage requirements:  For example, the Number data type can use 1, 2, 
4, 8, or 16 bytes. 
 
The domain of the data:  This refers to what can be stored in the column.  
For example, Text cannot be stored in a Number field. 
 
Establishing relationships:  Generally, it is more efficient to establish 
relationships between Number or Text columns. 
 
Sorting requirements:  Sorting Text values may return unexpected results 
and OLE Objects cannot be sorted. 
 
Indexing requirements:  Indexing Memo fields can create very large 
indexes and OLE Objects cannot be indexed. 
 
Calculation requirements:  Certain calculations cannot be performed on 
fields defined as Text or OLE Objects. 

 

Setting Column Data Types 
 Open a table in Design view. 
 Create a new field. 
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 Select the desired data type from the Data Type drop-down menu: 
 

 
 

 Close the table. 
 

Formatting Data Types 
 Open a table in Design view. 
 Select an existing field. 
 Set the desired field size in the Field Size text box. 
 Add an appropriate formatting symbol in the Format text box: 

 

 
 

 Close the table. 
 

Converting Between Data Types 
 Sometimes it may be necessary to change the data type for a column.  For 

example, it may be necessary to change from a Text field, which has a 
maximum length of 255 characters, to a Memo field which has a maximum 
length of 65,536 characters. 
 
Note:  Changing between data types can result in a loss of data. This can 
happen when converting from a larger data type to a smaller data type or 
converting between incompatible data types such as changing from Text to 
Number. 

 
To change a field to a different data type: 

 Open a table in Design view. 
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 Select an existing field. 
 Select the desired data type from the Data Type drop-down menu: 

 

 
 

 Close the table. 
 
 

Review Questions 
 
How would you: 

 Set a Primary Key? 
 Remove Non-Related Data? 
 Remove Redundant Data? 
 Remove Repeating Data? 
 Set Required Values in Columns? 
 Use the Relationship Tool? 
 Identify a Related Table? 
 Create Join Types? 
 Enforce Referential Integrity? 
 Work with Cascading Updates and Deletes? 
 Create a Single-Field Index? 
 Create a Multiple-Field Index? 
 Set the Index Sort Order? 
 Set Index Properties? 
 Delete Indexes? 
 Choose Appropriate Data Types? 
 Set Column Data Types? 
 Format Data Types? 
 Convert Between Data Types? 
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Designing Queries in Access 2002 
 
When you have completed this learning module you will have seen how to: 

 Create update queries 
 Create delete queries 
 Create append queries 
 Create make-table queries 
 Create a one-parameter query 
 Create a two-parameter query 
 Use wildcards as parameters 
 Create calculated fields 
 Use common functions in calculated fields 
 Create a two-table join 
 Add fields from different tables to the query grid 
 Remove tables from the query builder 
 
 

Creating Action Queries 
 

Creating Update Queries 
 An Update Query makes changes to a group of records.  Updates can be 

made in one or more tables. 
 
To create an Update Query: 

 Click Queries in the Objects pane. 
 Click the New button to open the New Query dialog box. 
 Select Design View. 
 Click OK: 

 

 
 

 Select a table from the Tables tab in the Show Table dialog box. 
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 Click Add: 
 

 
 

 Click Close.  A representation of the table appears in the query grid. 
 Click on the Query Type button on the Query Design toolbar: 

 

 
 

 Select Update Query to change from a Select Query to an Update Query: 
 

 
 

 Select a field from the Field drop-down menu:  
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 Select the Update To section of the query grid and type a value: 
 

 
 

 Click the Run button on the Query Design toolbar to execute the update: 
 

 
 

 Click Yes to apply the changes. 
 
Note:  There is no undo feature for the update action.  The change is 
permanent. 

 

 Close the query design window. 
 

Creating Delete Queries 
 A Delete Query deletes groups of records.  Deletes can be made in one or 

more tables. 
 
To create a Delete Query: 

 Click Queries in the Objects pane. 
 Click the New button.  This opens the New Query dialog box. 
 Select Design View. 
 Click OK. 
 Select a table from the Tables tab in the Show Table dialog box. 
 Click Add. 
 Click Close.  A representation of the table appears in the query grid. 
 Click the Query Type button on the Query Design toolbar. 
 Select Delete Query to change from a Select Query to a Delete Query: 

 

 
 

 Select a field from the Field drop-down menu. 
 Select the Criteria section of the query grid and type a value:  
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Note:  This delete query uses a where filter to limit which rows are deleted. 

 

 Click the Run button on the Query Design toolbar to execute the delete. 
 Click Yes to apply the changes:  

 

 
 
Note:  An error will occur if a relationship has been previously defined for 
this field.   
Click No to cancel or Yes to ignore the error and continue: 
 

 
 

 Close the query design window. 
 

Creating Append Queries 
 An Append Query adds groups of records to the end of a table.  Records can 

be added from one or more tables. 
 
To create an Append Query: 

 Click Queries in the Objects pane. 
 Click the New button.  This opens the New Query dialog box. 
 Select Design View. 
 Click OK. 
 Select a table from the Tables tab in the Show Table dialog box. 
 Click Add. 
 Click Close.  A representation of the table appears in the query grid. 
 Click the Query Type button on the Query Design toolbar. 
 Select Append Query to change from a Select Query to an Append Query: 
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 This opens the Append dialog box. 
 Select a table from the Table Name drop-down menu: 

 

 
 

 Click OK. 
 Select the desired fields to append: 

 

 
 

 Click the Run button on the Query Design toolbar to execute the update. 
 Click Yes to append the rows: 

 

 
 

 Close the query design window. 
 

Creating Make-Table Queries 
 A Make-Table Query creates a new table from data in another table.  

Records can be added from one or more tables. 
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To create a Make-Table Query: 

 Click Queries in the Objects pane. 
 Click the New button.  This opens the New Query dialog box. 
 Select Design View. 
 Click OK. 
 Select a table from the Tables tab in the Show Table dialog box. 
 Click Add. 
 Click Close.  A representation of the table appears in the query grid. 
 Click the Query Type button on the Query Design toolbar. 
 Select Make-Table Query to change from a Select Query to a Make-Table 

Query: 
 

 
 

 This opens the Make Table dialog box. 
 Select a table from the Table Name drop-down menu 

OR type a new table name: 
 

 
 

 Click OK. 
 Select the desired fields: 

 

 
 

 Click the Run button on the Query Design toolbar to execute the update. 
 Click Yes to paste the rows into the table:  
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Note:  There will now be a new table in the Tables section. 
 

 Close the query design window. 
 
 

Creating Parameter Queries 
 

Creating a One-Parameter Query 
 A parameter query is a special query that prompts a user for input.  This is 

useful for creating generic queries where users can specify custom select 
criteria. 

 
To create a one-parameter query: 

 Click Queries in the Objects pane. 
 Click the New button.  This opens the New Query dialog box. 
 Select Design View. 
 Click OK. 
 Select a table from the Tables tab in the Show Table dialog box. 
 Click Add. 
 Click Close.  A representation of the table appears in the query grid. 
 Select a field from the Field drop-down menu. 
 Add a prompt in the Criteria text box: 

 

 
 

 Click the Run button on the Query Design toolbar to execute the query.  
This opens the Enter Parameter Value dialog box. 

 Input a value. 
 Click OK: 
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 The results of the query are displayed. 
 Close the query results window. 
 

Creating a Two-Parameter Query 
 Click Queries in the Objects pane. 
 Click the New button.  This opens the New Query dialog box. 
 Select Design View. 
 Click OK. 
 Select a table from the Tables tab in the Show Table dialog box. 
 Click Add. 
 Click Close.  A representation of the table appears in the query grid. 
 Select a field from the Field drop-down menu. 
 Add two prompts in the Criteria text box: 

 

 
 

 Click the Run button on the Query Design toolbar to execute the query.  
This opens the first Enter Parameter Value dialog box. 

 Input a value. 
 Click OK: 

 

 
 

 This opens the second Enter Parameter Value dialog box. 
 Input a value. 
 Click OK: 
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 The results of the query are displayed. 
 Close the query results window. 
 

Using Wildcards as Parameters 
 Click Queries in the Objects pane. 
 Click the New button.  This opens the New Query dialog box. 
 Select Design View. 
 Click OK. 
 Select a table from the Tables tab in the Show Table dialog box. 
 Click Add. 
 Click Close.  A representation of the table appears in the query grid. 
 Select a field from the Field drop-down menu. 
 Add a wildcard prompt in the Criteria text box:  

 

 
 
Note:  The Like operator is used for pattern searches. 
 

 Click the Run button on the Query Design toolbar to execute the query.  
This opens Enter Parameter Value dialog box. 

 Input a value. 
 Click OK: 

 

 
 

 The results of the query are displayed. 
 Close the query results window. 
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Creating Calculated Columns in Queries 
 

Creating Calculated Fields 
 Click Queries in the Objects pane. 
 Click the New button.  This opens the New Query dialog box. 
 Select Design View. 
 Click OK. 
 Select a table from the Tables tab in the Show Table dialog box. 
 Click Add. 
 Click Close.  A representation of the table appears in the query grid. 
 Select a field from the Field drop-down menu. 
 Enter an expression for the calculated field: 

 

 
 

 Click the Run button on the Query Design toolbar to execute the query. 
 The results of the query are displayed. 
 Close the query results window. 
 

Using Common Functions in Calculated Fields 
 There are a large number of functions that can be used in calculated fields.  

Functions in Access can be divided into groups. Common groups are 
Date/Time, Financial, Math, and Text functions.  Some common functions 
within each group include: 
 
Date/Time:  Date, DatePart, Day, Hour, Minute. 
Financial:  FV, PV, IRR, Pmt. 
Math:  Exp, Rnd, Sqr. 
Text:  LTrim, RTrim, Replace, Len. 
 

 Functions will only work correctly when supplied with the correct number of 
arguments.  A tool included within Access, called the Expression Builder, 
simplifies using functions in calculated fields.  The Expression Builder is 
discussed later in this training manual. 

 
 

Joining Tables 
 

Creating a Two-Table Join 
 A two-table join links related fields between two different tables. 
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To create a two-table join: 

 Click Queries in the Objects pane. 
 Click the New button.  This opens the New Query dialog box. 
 Select Design View. 
 Click OK. 
 Select a table from the Tables tab in the Show Table dialog box. 
 Click Add. 
 Click Close.  A representation of the table appears in the query grid. 
 
To add another table to the query grid: 

 Click the Show Table button on the Query Design toolbar.  This opens the 
Show Table dialog box. 

 Select the desired table. 
 Click Add. 
 Create a join between the tables by dragging and dropping a field from the 

first table to the related field in the second table: 
 

 
 

 The final result will be a join link between the two tables: 
 

 
 

Adding Fields from Different Tables to the Query Grid 
 Select the desired field from the Field drop-down menu. 
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OR 
 

 Select the desired table from the Table drop-down menu: 
 

 
 

 Select the desired field from the Field drop-down menu: 
 

 
 

 Click the Run button on the Query Design toolbar to execute the query. 
 The results of the query are displayed. 
 Close the query results window. 
 

Removing Tables from the Query Builder 
 Right-click on the table you want to remove in the query grid. 
 From the pop-up menu, select Remove Table: 

 

 
 
OR from the main menu, select Edit > Delete: SAMPLE
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Review Questions 
 
How would you: 

 Create Update Queries? 
 Create Delete Queries? 
 Create Append Queries? 
 Create Make-Table Queries? 
 Create a One-Parameter Query? 
 Create a Two-Parameter Query? 
 Use Wildcards as Parameters? 
 Create Calculated Fields? 
 Use Common Functions in Calculated Fields? 
 Create a Two-Table Join? 
 Add Fields from Different Tables to the Query Grid? 
 Remove Tables from the Query Builder? 
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Designing Forms in Access 2002 
 
When you have completed this learning module you will have seen how to: 

 Choose an Appropriate Control 
 Place Controls on a Form 
 Move a Control 
 Resize a Control 
 Set Control Properties 
 Create Page Headers and Footers 
 Create Form Headers and Footers 
 Set Form Properties 
 Work with Identifiers 
 Create a Subform 
 Create a Form with Two Subforms 
 Create Nested Subforms 
 Delete a Subform 
 Create a Modal Pop-up Form 
 Create a Modeless Pop-up Form 
 Create a Switchboard 
 Edit a Switchboard Item 
 Delete a Switchboard 
 
 

Creating Data Entry Forms 
 

About Forms 
 Forms can be used for data entry, displaying data in a user-friendly format, 

and as a navigational tool. 
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Choosing an Appropriate Control 
 Controls are objects that can be placed on forms, reports, or data access 

pages that display data, perform actions, or can be used for visual display.  
Controls shipped with Access 2002 include: 
 
Text Boxes:  Used to display data on a form.  Text boxes can be bound to a 
data source or unbound to accept input or display a calculation. 
 
Labels:  Used to display text on a form.  Labels are useful for descriptive of 
instructional text.  Labels are not associated with a data source. 
 
List Boxes:  Used to display a pre-determined list of values.  List boxes are 
useful when limiting selection choices or when enforcing data integrity. 
 
Command Buttons:  Used to execute a pre-defined set of actions in a macro 
or event procedure written in visual basic. 
 
Check Boxes:  Used to set Yes/No values from an underlying query or 
table. 
 
Option Groups:  Used to select a limited list of choices.  Sometimes 
interchangeable with List Boxes when selecting from only a few pre-defined 
options. 
 
Toggle Buttons:  Used to set Yes/No values from an underlying query or 
table.  Useful when combined with an Option Group to select values that are 
Yes/No. 
 
Image:  Used when displaying a digital image on a form.  An example would 
be the display of a company logo. 
 
Tabbed Pages:  Used when presenting different sections of information as 
one logical set.  Useful when separating levels of information related to a 
common topic such as employee, company, or personal information. 
 
Rectangles and Lines:  Used when displaying limited geometric shapes.  
Useful when displaying breaks between fields or sections within a form. 
 
Subform:  An advanced control that displays child data that is related to 
data on the parent form.  Subforms are discussed later in this training 
manual. 

 

Placing Controls on a Form 
 Click Forms in the Objects pane. 
 Click the New button.  This opens the New Form dialog box. 
 Select Design View. 
 Select a data source for the form from the drop-down menu: 
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 Click OK. 
 Access opens into Form Design view showing the Detail area, Data 

Source, and Toolbox. 
 Click the desired control to place on the form on the Toolbox toolbar: 

 

 
 

 Click and drag the control in the Detail area of the form: 
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OR drag and drop a field from the data source to the Detail area of the 
form: 
 

 
 

Moving a Control 
 Select the control you want to move. 
 Place the cursor over the control until the cursor changes to a hand. 
 Drag the control to its new location: 

 

 
 

Resizing a Control 
 Select the control you want to resize. 
 Place the cursor over the control until the cursor changes to a double arrow. 
 Drag control to the desired size: 

 

 
 

Setting Control Properties 
 Control properties can be divided into five categories: 

 

SAMPLE



Microsoft Access XP - Intermediate Level Manual - Page 38 

FOR USE AT THE LICENSED SITE(S) ONLY 
 Cheltenham Courseware Pty. Ltd. 1995-2010 www.cheltenhamcourseware.com 

Format:  Sets visual properties for a control. 
Data:  Sets the underlying data source for a control. 
Event:  Sets action behavior for a control.  Typically used to tie a macro or 
event procedure to a specific control action. 
Other:  Sets the behavior for the control such as tab stop behavior or the tab 
order. 
All:  Used to view all categories in the same pane. 

 
To set a property on a control: 

 Right-click on the control. 
 From the pop-up menu, select Properties.  This opens the control 

properties dialog box: 
 

 
 

 Select the desired control properties. 
 
Note:  The available control properties will vary depending on the type of 
control used. 

 

Creating Page Headers and Footers 
 Page headers and page footers appear at the top and bottom of each page 

and can display information such as a column heading. 
 
To create page headers and footers: 

 Right-click in the Detail area of the form. 
 From the pop-up menu, select Page Header/Footer.  This opens the Page 

Header and Page Footer panes: 
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 Place the desired control on the page header or page footer. 
 

Creating Form Headers and Footers 
 Form headers and form footers appear at the top and bottom of each page 

and can display items such as the date, page number, or company logo. 
 
To create form headers and footers: 

 Right-click in the Detail area of the form. 
 From the pop-up menu, select Form Header/Footer.  This opens the Form 

Header and Form Footer panes. 
 Place the desired control on the form header or form footer. 

 
Note:  Page headers and footers and Form headers and footers can 
both appear on the same form. 

 

Setting Form Properties 
 Form properties can be divided into five categories: 

 
Format:  Sets visual properties for a form. 
Data:  Sets the underlying data source for a form. 
Event:  Sets action behavior for a form.  Typically used to tie a macro or 
event procedure to a specific form action. 
Other:  Sets the behavior for the form such as the modal or pop-up 
properties. 
All:  Used to view all categories in the same pane. 

 
To set a form property: 

 Right-click on the form. 
 From the pop-up menu, select Properties.  This opens the Form properties 

dialog box: 
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 Select the desired form properties. 
 

Working with Identifiers 
 When referencing an object or property in another form or subform, it is 

necessary to use an object identifier.  This is the fully qualified name of the 
object or property.  For example, when referencing the order date in the 
Orders form, it is necessary to use the object identifier 
Forms![Orders]![OrderDate]. 

 
To add an object identifier in a control: 

 Right-click on a control. 
 From the pop-up menu select Properties.  This opens the control 

properties dialog box: 
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 Click the Data tab. 
 Click the Expression Builder button next to the Control Source field: 

 

 
 

 This opens the Expression Builder. 
 Add the desired object from the Expression Builder window: 

 

 
 

 The external object is now referenced in the current control using its Object 
Identifier: 
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Working with Subforms 
 

Creating a Subform 
 A subform is a form inside another form.  Subforms are useful for displaying 

one-to-many relationships where the main form displays the one side of 
the relationship and the subform displays the many side of the relationship.  
A form/subform combination is sometimes called a parent/child form. 

 
To add a subform to a form: 

 Open a form in Design view. 
 Click the Control Wizards button on the Toolbox toolbar: 

 

 
 

 Click the Subform/Subreport button on the Toolbox toolbar: 
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 Click and drag the control in the Detail area of the form: 
 

 
 

 This opens the SubForm Wizard. 
 Select the Use existing Tables and Queries option button. 
 Click Next: 

 

 
 

 Select a table from the Tables/Queries drop-down menu. 
 Select a field from the Available Fields area. 
 Click the single right arrow to add the field 

OR click the double right arrow to add all fields: 
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 Click Next. 
 Select the Choose from a list option button 

OR select the Define my own option button: 
 

 
 
Note:  If Define my own is selected, the wizard will require the link 
between the main form and subform to be manually defined. 

 

 Click Next. 
 Type a name for the subform. 
 Click Finish. 
 

Creating a Form with Two Subforms 
 A form with two subforms is often used when one subform is related to 

another subform within the same main form.  The first subform is related 
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to a key value in the main form.  The second subform is related to the first 
subform by a different key value. 

 
To create a form with two subforms: 

 Click Forms in the Objects pane. 
 Click the New button on the database window.  This opens the New Form 

dialog box. 
 Select Form Wizard. 
 Click OK. 
 Select a table from the Tables/Queries drop-down menu. 
 Add the desired fields. 
 Select another table from Tables/Queries drop-down menu. This will be the 

first subform. 
 Add the desired fields. 
 Select another table from Tables/Queries drop-down menu. This will be the 

second subform. 
 Add the desired fields. 
 Click Next. 
 Select the desired view in the How do you want to view your data dialog 

box. 
 Select the Form with subform(s) option button: 

 

 
 

 Click Next. 
 Select the desired layout for each subform: 
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 Click Next. 
 Select the desired form style. 
 Click Next. 
 Enter the title for the main form and each subform: 

 

 
 

 Click Finish. 
 

Creating Nested Subforms 
 Creating a nested subform is similar to creating a form with two subforms.  

The main difference between the two is that the second subform is 
embedded in the first subform instead of in the main form. 
 

To create a nested subform: 
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 Create a subform within a main form. 
 
Note:  Creating subforms within a form was previously discussed in this 
training manual. 
 

 Click the Subform/Subreport control button on the Toolbox toolbar. 
 Click and drag the control in the Detail area of the existing subform.  This 

opens the SubForm Wizard. 
 Select the Use existing Tables and Queries option button. 
 Click Next. 
 Select a table from the Tables/Queries drop-down menu. 
 Select a field from the Available Fields area. 
 Click the single right arrow to add a field 

OR click the double right arrow to add all fields. 
 

 Click Next. 
 Select the Choose from a list option button 

OR select the Define my own option button. 
 
Note:  If Define my own is selected, the wizard will require the link 
between the main form and subform to be manually defined. 

 

 Click Next. 
 Type a name for the subform. 
 Click Finish. 
 

Deleting a Subform 
 Open the main form in Design view. 
 Right-click on the subform. 
 From the pop-up menu, select Cut. 

 
OR 
 

 Right-click on the subform in the Forms database window. 
 From the pop-up menu, select Delete. 

 
Note:  Deleting the subform directly from the Forms database window 
without deleting it from the parent form will cause an error when opening the 
parent form. 

 
 

Creating Pop-up Forms 
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Creating a Modal Pop-up Form 
 A modal form is one that has exclusive focus when it is open.  Other 

database objects are not accessible while the form is open. 
 
To create a modal pop-up form: 

 Open a form in Design view. 
 Right-click on the main form area: 

 

 
 

 From the pop-up menu, select Properties. 
 Click the Other tab. 
 Select Yes from the Pop Up drop-down menu: 
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 Select Yes from the Modal drop-down menu: 
 

 
 

Creating a Modeless Pop-up Form 
 A modeless form is one that has non-exclusive focus when it is open.  Other 

database objects are accessible while the form is open. 
 
To create a modeless pop-up form: 

 Open a form in Design view. 
 Right-click on the main form area. 
 From the pop-up menu, select Properties. 
 Click the Other tab. 
 Select Yes from the Pop Up drop-down menu. 
 Select No from the Modal drop-down menu. 
 
 

Working with Switchboards 
 

Creating a Switchboard 
 A Switchboard is a special form that acts as a central navigation aide to 

help users access objects within a database.  Switchboards are useful when 
creating a custom user interface that allows a fixed number of options. 

 
To create a Switchboard: 

 From the main menu, select Tools > Database Utilities > Switchboard 
Manager.  This opens the Switchboard Manager dialog box: 
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 Click New.  This opens the Create New dialog box. 
 Type a new name for the switchboard: 

 

 
 

 Click OK. 
 Click Edit to edit the switchboard properties. 
 Click New.  This opens the Edit Switchboard Item dialog box. 
 Type the name of the switchboard item in the Text box. 
 Select a command from the Command drop-down menu. 
 Select the object to open in the third drop-down menu: 

 

 
 
Note:  The third drop-down menu will change depending on the type of 
command selected.  For example, if the Open Report command is selected 
then the third drop-down menu is named Report. 
 

 Click OK. 
 Click Close. 
 
To make the new switchboard the default: 

 Click the Make Default button: 
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 Click Close. 
 

Editing a Switchboard Item 
 From the main menu, select Tools > Database Utilities > Switchboard 

Manager.  This opens the Switchboard Manager dialog box. 
 Select the switchboard to edit. 
 Click Edit.  This opens the Edit Switchboard Page dialog box. 
 Select the switchboard item to edit. 
 Click Edit. 
 Make the edits you want. 
 Click OK. 
 Click Close. 
 Click Close again to exit the Switchboard Manager dialog box. 
 

Deleting a Switchboard 
 From the main menu, select Tools > Database Utilities > Switchboard 

Manager.  This opens the Switchboard Manager dialog box. 
 Select the switchboard to delete. 
 Click Delete. 

 
Note:  The default switchboard cannot be deleted. 
 

 Click Yes to confirm the delete. 
 Click Close to exit the Switchboard Manager dialog box. 
 
 

Review Questions 
 
How would you: 

 Choose an Appropriate Control? 
 Place Controls on a Form? 
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 Move a Control? 
 Resize a Control? 
 Set Control Properties? 
 Create Page Headers and Footers? 
 Create Form Headers and Footers? 
 Set Form Properties? 
 Work with Identifiers? 
 Create a Subform? 
 Create a Form with Two Subforms? 
 Create Nested Subforms? 
 Delete a Subform? 
 Create a Modal Pop-up Form? 
 Create a Modeless Pop-up Form? 
 Create a Switchboard? 
 Edit a Switchboard Item? 
 Delete a Switchboard? 
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End of the preview sample 
 
 

 
 
This sample is approximately half of the full course.  Please see the table of contents at the 
beginning of this document to see the full list of topics covered in the full course. 
 
To purchase the rights to use the full training manuals at your training centre please see our 
web site at:  
 

http://www.cctglobal.com 
 
A courseware licence allows you to make unlimited copies for use at your training centre. 
 

 
 
In addit ion you get HTML formatted versions of each 
course, included w ith our printable coursew are. 
 
Invest in a complete Computer Courseware Library, 
including Windows 7 & Office 2010 
The most cost effective courseware solution for your IT 
training needs. Get ALL our courses, and all new  courses 
released w ithin 12 months. 
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