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Course Basics 
 
 

Toolbars 
 
 

The Title Bar 
 The title bar is displayed along the top of almost all program, folder and dialog 

box windows.  It is used to display information such as the name of the 
application (or folder) and the document you are working on.  Information which 
is displayed here may vary.  The example shown illustrates the title bar for a 
program called Microsoft Word, in which a document called Document1 has 
been opened or saved: 
 

 
 
 

The Menu Bar 
 The menu bar is located under the title bar, and contains a series of drop down 

menus.  The example shown illustrates the Microsoft Word Menu Bar: 
 

 
 
 

To execute Menu commands 

 In most cases, you are asked to use the mouse to execute a series of menu 
commands (e.g., File > Save As).  What this means is that you select File from 
the main menu, followed by Save As: 
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The Tool Bar 
 The tool bar contains a series of icons, which allow you to achieve a desired 

effect as quickly as possible.  In the example shown, taken from the Microsoft 
Word Formatting toolbar, to make the selected text bold, you would click on the 
Bold icon: 
 

 
 
 

The Status Bar 
 Most application windows have a status bar displayed along the bottom of the 

window.  In the example illustrated, taken from Microsoft Word, the status bar 
conveys information about the page within the document which you are working 
on, along with other relevant information: 
 

 
 
 

The Scroll Bar 
 When a program or folder needs to display information within a window, two 

sets of scroll bars may be displayed along the bottom and right side of the 
window.  By using the scroll bars it is possible to move to any position within a 
document and also work on a document many times bigger than your physical 
screen size. 

 
 

To move up and down within a window (using the scroll bar) 

 To scroll upwards in a window, click on the upwards-pointing arrow at the top of 
the vertical scroll bar:   

 To move downwards in a window, click on the downwards-pointing arrow at the 
bottom of the vertical scroll bar:   

 
 

To move right to left within a window 

 To move to the right-hand side of a window, click on the right-hand arrow on 
the horizontal scroll bar:   

 To move to the left-hand side of a window, click on the left-hand arrow on the 
horizontal scroll bar:   
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File Management 
 
 

Opening Files 
 From the main menu, select File > Open command or click on the Open icon 

and select the required file from the dialog box displayed: 
 

 
 

 
 

 Use the Look in drop-down menu to select the drive or folder which contains 
the file you want. 

 To open the file you require either double-click on the file name 
or select the file name by clicking on it, and then click on the Open button. 

 
 

Saving Files 
 
 

To save a new document 

 From the main menu, select File > Save command or click on the Save icon 
and from the dialog box displayed select the required folder.  Enter a file name 
and then click on the Save button: 
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 After you have saved the file for the first time, clicking on the Save icon will 
automatically save your document with the filename you gave it.  It does not 
give you the option to rename. 

 
 

To save a document under another name and/or location 
 The Save As command can be used to save a file under a different name, to 

save a file in a different word processor format, or to save a file to a different 
drive and/or folder.  From the main menu, choose File > Save As command. 
 
Note: The File > Save As command will rename the document on the screen 
so that you can keep the earlier version, as well as saving any changes you have 
made. 

 
 

To create a new folder in which to save your document 

 Click on the Create New Folder icon, displayed within the Save As dialog box. 
 This will display the New Folder dialog box.  Enter the name of the new folder, 

and then click on the OK button: 
 

 
 
Note: The folder will be created under the current folder. 
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Closing Files 
 Click on the Close Window icon displayed at the top-right of the document 

window.  Be sure to click on the Close Window icon, (as opposed to the Close 
icon): 
 

 
 
 

Installing the Sample Files 
 

 Use Windows Explorer to create a folder called Access 2003 Intermediate 
Samples, in the My Documents folder. 

 Copy the sample files for this course to the My Documents\ Access 2003 
Intermediate Samples folder. 

 If these files have been copied to your network server, then ask your 
trainer/supervisor for more information about how to copy these files to your 
PC’s hard disk. 
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Using the Northwind Sample Database 
 
 

Installing the Northwind Database 
 

 Click the File Search button on the database toolbar: 
 

 
 

 In the Search text box of the Basic File Search task pane, type Northwind. 
In the Search in area of the task pane, choose Everywhere from the drop 
down menu. 

 Click Go. 
 If Northwind.mdb appears in the Search Results, double-click on the file to 

open it and proceed to the next chapter. 
 If Northwind is not found in the Search Results it will need to be installed. 
 Insert the Microsoft Office 2003 CD-ROM in the CD-ROM drive. 
 Double-click Setup. 

 
Note: If your computer has autorun enabled, you will be presented directly with 
the Microsoft Office 2003 setup screen. 
 

 Select Add or Remove Features. 
 Click Next. 
 Make sure that the Access box is checked, and that the Choose advanced 

customization of applications checkbox is also selected.  Click Next: 
 

 
 

 Under Choose update options for applications and tools, select the 
Microsoft Office Access subtree. 
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 Under Sample Databases, select Run all from My Computer: 
 

  
 

 Click Update. 
 Once the installer completes, click OK to finish. 
 Once the Northwind database is installed, search for it again and open it.  

Proceed to the next chapter. 
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Designing Tables in Access 2003 
 
 

Normalizing Data 
 
 

Understanding Primary Keys 
 Open the Northwind database. 
 Select the Don't show this screen again box, and click OK to close the 

Northwind splash screen: 
 

 
 

 In the displayed Main Switchboard dialog box, click on the Display Database 
Window button: 
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 Click on Tables in the Objects pane: 
 

 
 

 Select the Categories table, and click on the Design button to open the table 
in Design view: 
 

 
 

 Observe the key symbol to the left of the CategoryID field, which signifies that 
the CategoryID field is set as the primary key.  Note that no other fields are 
set as primary keys, as each table can have only one: 
 

 
 

 Close the table without saving the changes. 
 
 

Setting Required Values in Columns 
 Click on Tables in the Objects pane. 
 Open the Categories table in Design view. 
 Click within the Picture field to select it: 

 

 
 

 Find the General tab in the lower-left portion of the design window. 
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 In the General tab select the Required field. 
 Choose Yes to make the field required: 

 

 
 

 Close the table without saving the changes 
 Close the Northwind database. 
 
 

Establishing Relationships 
 

 Open the Northwind database. 
 In the displayed Main Switchboard dialog box, click on the Display Database 

Window button. 
 Click the Relationships button on the Database toolbar: 

 

 
 

 Right-click on the relationship between the Employees and Orders tables. 
 From the pop-up menu, select Delete: 

 

 
 

 Click the Yes button when prompted to delete the relationship. 
 To re-create the relationship between the Employees and Orders tables, drag 

the EmployeeID field from the Employees table to the EmployeeID field in 
the Orders table. 
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 Click Join Type in the Edit Relationships dialog box: 
 

 
 

 Select the option button labeled 2: 
 

 
 

 Click OK. 
 Check the Enforce Referential Integrity box. 
 Check the Cascade Update Related Fields box. 
 Check the Cascade Delete Related Fields box: 

 

 
 

 Click Create. 
 Click the Save button. 
 Close the Relationships window. 
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Enforcing Referential Integrity 
 Click the Relationships button on the Database toolbar: 

 

 
 

 Right-click on the relationship between the Categories and Products tables. 
 From the pop-up menu, select Edit Relationship.  This opens the Edit 

Relationships dialog box. 
 Check the Enforce Referential Integrity box, if it is not already selected: 

 

 
 

 Click OK. 
 Close the Relationships window. 
 Close the Northwind database. 
 
 

Working with Indexes 
 
 

Creating a Single-Field Index 
 Open the Northwind database. 
 In the displayed Main Switchboard dialog box, click on the Display Database 

Window button. 
 Click on Tables in the Objects pane. 
 Open the Customers table in Design view. 
 Click the Indexes button on the Table Design toolbar: 

 

 
 

 Type ContactName in the Index Name column. 
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 Select ContactName from the drop-down menu in the Field Name column: 
 

 
 

 Select Descending from the drop-down menu in the Sort Order column. 
 Select Yes from the Ignore Nulls drop-down menu in the Index Properties 

area: 
 

 
 

 Click the Close button on the Indexes title bar. 
 Click the Save button. 
 Close the table. 
 
 

Creating a Multiple-Field Index 
 Click on Tables in the Objects pane. 
 Open the Customers table in Design view. 
 Click the Indexes button on the Table Design toolbar 

 
OR from the main menu, select View > Indexes. 
 

 This opens the Indexes design grid. 
 Type Address in the Index Name column. 
 Select Address from the drop-down menu in the Field Name column. 
 Click on the next row in the Field Name column, and choose City. 
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 Click on the next row in the Field Name column, and choose Country: 
 

 
 

 Click the Close button on the Indexes title bar. 
 Click the Save button. 
 Close the table. 
 
 

Setting the Index Sort Order 
 Click on Tables in the Objects pane. 
 Open the Customers table in Design view. 
 Click the Indexes button on the Table Design toolbar 

 
OR from the main menu, select View > Indexes. 
 

 This opens the Indexes design grid.  Select the Address index, and click the 
drop-down menu in the Sort Order column on the first row, as illustrated.  
Select Descending to change the sort order: 
 

 
 

 Click the Close button on the Indexes title bar. 
 Click the Save button. 
 Close the table. 
 
 

Setting Index Properties 
 Click on Tables in the Objects pane. 
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 Open the Customers table in Design view. 
 Click the Indexes button on the Table Design toolbar 

 
OR from the main menu, select View > Indexes. 
 

 This opens the Indexes design grid. 
 Select the Address index. 
 Select Yes from the Unique property drop-down menu in the Index 

Properties section. 
 

 
 

 Now change the Unique property back to No. 
 Click the Close button on the Indexes title bar. 
 Close the table without saving the changes. 
 
 

Deleting Indexes 
 Click on Tables in the Objects pane. 
 Open the Customers table in Design view. 
 Click the Indexes button on the Table Design toolbar 

 
OR from the main menu, select View > Indexes. 
 

 This opens the Indexes design grid. 
 Right-click on the Address index. 
 From the pop-up menu, select Delete Rows: 
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 Repeat the steps to delete the other 2 remaining Address index rows.  Your 
Indexes design grid should resemble the following: 
 

 
 

 Click the Close button on the Indexes title bar. 
 Click the Save button. 
 Close the table. 
 Close the Northwind database. 
 
 

Working with Data Types 
 
 

Setting and Formatting Column Data Types 
 Open the Northwind database. 
 In the displayed Main Switchboard dialog box, click on the Display Database 

Window button. 
 Click on Tables in the Objects pane. 
 Open the Customers table in Design view. 
 Type a new field named CompanySlogan in the Field Name column: 
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 Select Text from the Data Type drop-down menu. 
 In the Field Properties area, set the Field Size to 100: 

 

 
 

 Click the Save button. 
 Close the table. 
 
 

Converting Between Data Types 
 Click on Tables in the Objects pane. 
 Open the Customers table in Design view. 
 Select the CompanySlogan in the Field Name column. 
 Select Memo from the Data Type drop-down menu: 

 

 
 

 Close the table without saving the changes. 
 Close the Northwind database. 
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Designing Queries in Access 2003 
 
 

Creating Action Queries 
 Open the Northwind database. 
 In the displayed Main Switchboard dialog box, click on the Display Database 

Window button. 
 Click on Queries in the Objects pane. 
 Click the New button to open the New Query dialog box. 
 Select Design View. 
 Click OK: 

 

 
 

 Select Products from the Tables tab in the Show Table dialog box. 
 Click Add: 

 

 
 

 Click Close. 
 Click on the Query Type drop-down menu on the Query Design toolbar. 
 Select Update Query: 
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 Select UnitPrice from the Field drop-down menu. 
 Select the Update To section of the query grid and type [UnitPrice]*2: 

 

 
 

 Click the Run button on the Query Design toolbar to execute the update: 
 

 
 

 Click Yes to apply the changes. 
 Click the Save button.  Enter Multiply Unit Price by Two as the query name: 

 

 
 

 Click OK. 
 Right-click on the Products table in the query window. 
 From the pop-up menu, select Remove Table: 

 

 
 

 Click the Show Table button on the Query Design toolbar: 
 

 
 

 Select Orders from the Tables tab in the Show Table dialog box. 
 Click Add. 
 Click Close 
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 Click the Query Type drop-down menu on the Query Design toolbar. 
 Select Delete Query: 

 

 
 

 Select OrderID from the Field drop-down menu. 
 Type 10249 in the Criteria section of the query grid: 

 

 
 

 Click the Run button on the Query Design toolbar to execute the delete. 
 Click Yes to apply the changes. 
 From the main menu, select File > Save As. 
 Type Delete OrderID 10249. 
 Click OK. 
 Close the query window. 
 Close the Northwind database. 
 
 

Creating Parameter Queries 
 
 

Creating a One-Parameter Query 
 Open the Northwind database. 
 In the displayed Main Switchboard dialog box, click on the Display Database 

Window button. 
 Click on Queries in the Objects pane. 
 Click the New button to open the New Query dialog box. 
 Select Design View. 
 Click OK. 
 Select Products from the Tables tab in the Show Table dialog box. 
 Click Add: 
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 Click Close. 
 Select ProductID, ProductName, and SupplierID from the Field drop-down 

menus. 
 In the Criteria text box under ProductName, type [Enter a Product Name]: 

 

 
 

 Click the Run button on the Query Design toolbar to execute the query. 
 Type Chai. 
 Click OK: 

 

 
 

 View the result: 
 

 
 

 Click the Save button. Save the query as Search By Product Name. 
 Click OK. 
 Close the query. 
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Creating a Two-Parameter Query 
 Click Queries in the Objects pane. 
 Click the New button.  This opens the New Query dialog box. 
 Select Design View. 
 Click OK. 
 Select Orders from the Tables tab in the Show Table dialog box. 
 Click Add. 
 Click Close.  A representation of the table appears in the query grid. 
 Select ShippedDate and OrderId from the Field drop-down menus. 
 Type Between [Beginning Date] and [Ending Date] in the Criteria text box in the 

ShippedDate column: 
 

 
 

 Click the Run button on the Query Design toolbar to execute the query. This 
opens the first Enter Parameter Value dialog box. 

 Input 01/01/97. 
 Click OK: 

 

 
 

 This opens the second Enter Parameter Value dialog box. 
 Input 01/01/98. 
 Click OK: 

 

 
 

 The results of the query are displayed: 
 

SAMPLE
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 Close the query results window without saving the changes. 
 
 

Using Wildcards as Parameters 
 Click Queries in the Objects pane. 
 Click the New button. This opens the New Query dialog box. 
 Select Design View. 
 Click OK. 
 Select Products from the Tables tab in the Show Table dialog box. 
 Click Add. 
 Click Close.  A representation of the table appears in the query grid. 
 Select a ProductName, SupplierID, and CategoryID from the Field drop-

down menus. 
 Type Like [Enter the wildcard character(s): ] & "*" in the Criteria text box of the 

ProductName field: 
 

 
 

 Click the Run button on the Query Design toolbar to execute the query.  This 
opens Enter Parameter Value dialog box. 

 Input Chai. 
 Click OK: 

 

SAMPLE
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 The results of the query are displayed. 
 Close the query results window without saving the changes. 
 Close the Northwind database. 
 
 

Creating Calculated Columns in Queries 
 

 Open the Northwind database. 
 In the displayed Main Switchboard dialog box, click on the Display Database 

Window button. 
 Click Queries in the Objects pane. 
 Click the New button to open the New Query dialog box. 
 Select Design View. 
 Click OK: 

 

 
 

 Select Products from the Tables tab in the Show Table dialog box. 
 Click Add. 
 Click Close. 
 Select ProductName and UnitPrice from the Field drop-down menu. 
 In the next field type [UnitPrice]*10: 

 

 
 

SAMPLE
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 Click the Run button on the Query Design toolbar to execute the query: 
 

 
 
Note: Access automatically displays the calculated column as Expr1. 
 

 Click the Save button. Save the query as UnitPrice * 10. 
 Click OK. 
 Close the query. 
 Close the Northwind database. 
 
 

Joining Tables 
 
 

Creating a Two-Table Join 
 Open the Northwind database. 
 In the displayed Main Switchboard dialog box, click on the Display Database 

Window button. 
 Click Queries in the Objects pane. 
 Click the New button to open the New Query dialog box. 
 Select Design View. 
 Click OK: 

 

 
 

 Select Products from the Tables tab in the Show Table dialog box. 
 Click Add. 

SAMPLE
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 Select Unit Price * 10 from the Queries tab in the Show Table dialog box: 
 

 
 

 Click Add. 
 Click Close. 
 Create a join between the tables by dragging and dropping the ProductName 

field from the Products table to the ProductName field in the Unit Price * 10 
query: 
 

 
 

 For the first field, select Products.ProductName from the Field drop-down 
menu: 
 

 
 

 For the second field, select Products.QuantityPerUnit from the Field drop-
down menu: 

 For the third field, select UnitPrice * 10.Expr1 from the Field drop-down 
menu: 
 

SAMPLE
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 Click the Run button on the Query Design toolbar to execute the query. 
 View the results: 

 

 
 

 Click the Save button. Save the query as Join Product and Price * 10. 
 Click OK. 
 Close the query window. 
 
 

Removing Tables from the Query Builder 
 Click Queries in the Objects pane. 
 Click the New button to open the New Query dialog box. 
 Select Design View. 
 Click OK: 

 

 
 

 Select Products from the Tables tab in the Show Table dialog box. 
 Click Add. 

SAMPLE
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 Select Unit Price * 10 from the Queries tab in the Show Table dialog box: 
 

 
 

 Click Add. 
 Click Close. 
 Right-click on the Products table. 
 From the pop-up menu, select Remove Table: 

 

 
 
OR from the main menu, select Edit > Delete: 
 

 
 

 Close the query window without saving the changes. 
 Close the Northwind database. 
 

SAMPLE
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Designing Forms in Access 2003 
 
 

Creating Data Entry Forms 
 

 Open the Northwind database. 
 In the displayed Main Switchboard dialog box, click on the Display Database 

Window button. 
 Click Forms in the Objects pane. 
 Click the New button. 
 Select Design View. 
 Select Products from the drop-down menu. 
 Click OK: 

 

 
 
Note: Close the Form properties dialog box if it appears. 
 

 Drag and drop the ProductName and UnitPrice fields from the Products data 
source to the Detail area of the form: 
 

 
 

 Select the ProductName control by clicking on it. 
 Place the cursor over the control until the cursor changes to a hand. 
 Click and drag the control slightly to the right: 

 

SAMPLE
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 Repeat the above instructions to move the UnitPrice control so that it is aligned 
with the ProductName control: 
 

 
 

 Select the ProductName control by clicking on it. 
 Place the cursor over the control until the cursor changes to a double arrow. 
 Click and drag the control to a smaller size, as illustrated: 

 

 
 

 Repeat the above instructions to move the UnitPrice control so that it is the 
same size as the ProductName control: 
 

 
 

 Right-click on the ProductName control. 
 From the pop-up menu, select Properties. 
 Select the Format tab. 

SAMPLE
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 From the Special Effect drop down-menu, select Raised: 
 

 
 

 Close the dialog box. 
 Right-click in the Detail area of the form. 
 From the pop-up menu, select Page Header/Footer. 
 Click the Label control on the Toolbox toolbar: 

 

 
 
Note: From the main menu, select View > Toolbox if the Toolbox toolbar is 
not open. 
 

 Place the Label control on the page footer section of the form: 
 

 
 

 Type Product Entry Form: 
 

 
 

 Right-click in the Detail area of the form. 
 From the pop-up menu, select Form Header/Footer.  This opens the Form 

Header and Form Footer panes. 
 Click the Label control on the Toolbox toolbar: 
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 Place the Label control on the form header section of the form: 
 

 
 

 Type Products: 
 

 
 

 Click the Save button.  Save the form as Product Entry Form. 
 Click OK. 
 Close the form. 
 Close the Northwind database. 
 
 

Working with Subforms 
 
 

Creating a Subform 
 Open the Northwind database. 
 In the displayed Main Switchboard dialog box, click on the Display Database 

Window button. 
 Click Forms in the Objects pane. 
 Open Product Entry Form in Design view. 
 Click the Subform/Subreport button on the Toolbox toolbar: 
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 Create a subform in the Detail area of the form: 
 

 
 

 This will open the SubForm Wizard dialog box. 
 Select the Use existing Tables and Queries option button. 
 Click Next: 

 

 
 

 Select Table: Categories from the Tables/Queries drop-down menu. 
 Add the CategoryID, CategoryName and Description fields: 
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 Click Next. 
 Select the Choose from a list option button: 

 

 
 

 Click Next. 
 Type Show Categories Subform as the name of the subform. 
 Click Finish: 

 SAMPLE
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 Save the changes to the Product Entry Form. 
 Close the form. 
 
 

Creating a Form with Two Subforms 
 Click Forms in the Objects pane. 
 Click the New button on the database window.  This opens the New Form 

dialog box. 
 Select Form Wizard. 
 Click OK. 
 Select Table: Categories from the Tables/Queries drop-down menu. 
 Add the CategoryID, CategoryName and Description fields: 

 

 
 

 Select Table: Products from the Tables/Queries drop-down menu.  This will 
be the first subform. 

 Add the ProductID, ProductName and CategoryID fields: 
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 Select Table: Orders from Tables/Queries drop-down menu.  This will be the 
second subform. 

 Add the OrderID field: 
 

 
 

 Click Next. 
 Select the by Categories view in the How do you want to view your data dialog 

box. 
 Select the Form with subform(s) option button: 

 SAMPLE
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 Click Next. 
 Ensure that the Datasheet layout option buttons are selected for both of the 

subforms: 
 

 
 

 Click Next.  
 Select the Sumi Painting form style: 

 SAMPLE
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 Click Next. 
 Enter the following titles for the form and each subform: 

 

 
 

 Click Finish. 
 Click the down arrow on the View button on the Form Design toolbar, and 

select Design View: 
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 Right-click on the Products subform. 
 From the pop-up menu, select Cut: 

 

 
 

 Close the form without saving the changes. 
 Close the Northwind database. 
 
 

Creating Pop-up Forms 
 
 

Creating a Modal Pop-up Form 
 Open the Northwind database. 
 In the displayed Main Switchboard dialog box, click on the Display Database 

Window button. 
 Click Forms in the Objects pane. 
 Open Product Entry Form in Design view. 
 If the Form properties dialog box is not open, right-click on the title bar. 
 From the pop-up menu, select Properties. 
 Click the Other tab. 
 Select Yes from the Pop Up drop-down menu: 
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 Select Yes from the Modal drop-down menu: 
 

 
 

 Close the Form properties dialog box. 
 Save the changes to the Product Entry Form. 
 Close the form. 
 Close the Northwind database. 
 
 

Working with Switchboards 
 

 Open the Northwind database. 
 In the displayed Main Switchboard dialog box, click on the Display Database 

Window button. 
 From the main menu, select Tools > Database Utilities > Switchboard 

Manager. 
 If a warning dialog box appears, click Yes to create a switchboard. 
 Click New in the Switchboard Manager dialog box. 
 Type Sample Switchboard for the name of the switchboard: 

 

SAMPLE
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 Click OK. 
 Select Sample Switchboard. 
 Click Edit. 
 Click New: 

 

 
 

 Type Open Product Entry Form in the Text field. 
 Select Open Form in Add Mode from the Command drop-down menu. 
 Select Product Entry Form in the Form drop-down menu: 

 

 
 

 Click OK. 
 Click Close. 
 Click the Make Default button: 

 SAMPLE
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 Click Close. 
 Close the Northwind database. 
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Designing Reports in Access 2003 
 
 

Working with Standard Reports 
 

 Open the Northwind database. 
 In the displayed Main Switchboard dialog box, click on the Display Database 

Window button. 
 Click Reports in the Objects pane. 
 Click the New button. 
 Select Design View. 
 Select Products from the drop-down menu. 
 Click OK: 

 

 
 

 Drag and drop the ProductName, UnitPrice, and UnitsInStock fields from 
the products data source to the Detail area of the report. 

 Cut the Product Name, Unit Price, and Units In Stock labels from the Detail 
area of the report and paste in the Page Header area of the report. 

 Rearrange the labels and controls as shown below: 
 

 
 

 Right-click in the Detail area of the report. 
 From the pop-up menu, select Report Header/Footer. 

SAMPLE
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 Click the Label control on the Toolbox toolbar: 
 

 
 

 Place the Label control on the Report Footer section of the report: 
 

 
 

 Type Products Report: 
 

 
 

 Right-click in the detail area of the report. 
 From the pop-up menu, select Sorting and Grouping. 
 Select UnitPrice from the Field/Expression drop-down menu. 
 Select the Descending sort order from the Sort Order drop-down menu: 

 

 
 

 Close the Sorting and Grouping dialog box. 
 Click the Save button. Save the form as Products Report. 
 Click OK. 
 Close the report. 
 Close the Northwind database. 
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Working with Pop-up Reports 
 

 Open the Northwind database. 
 In the displayed Main Switchboard dialog box, click on the Display Database 

Window button. 
 Click Reports in the Objects pane. 
 Open Products Report in Design view. 
 Right-click on the report title bar. 
 From the pop-up menu, select Properties. 
 Click the Other tab. 
 Select Yes from the Pop Up drop-down menu: 

 

 
 

 Select Yes from the Modal drop-down menu: 
 

 
 

 Close the Properties dialog box. 
 Close the report without saving the changes. 
 Close the Northwind database. 
 

SAMPLE
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Working with Subreports 
 
 

Creating a Subreport 
 Open the Northwind database. 
 In the displayed Main Switchboard dialog box, click on the Display Database 

Window button. 
 Click Reports in the Objects pane. 
 Click the New button. 
 Select Design View. 
 Select Categories from the drop-down menu. 
 Click OK: 

 

 
 

 Drag and drop the CategoryName and Description fields from the Categories 
data source to the Detail area of the report. 

 Resize the labels and controls as shown below: 
 

 
 
SAMPLE
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 Click the Subform/Subreport button on the Toolbox toolbar: 
 

 
 

 Create a subreport in the Detail area of the form: 
 

 
 

 Select the Use existing Tables and Queries option button. 
 Click Next: 

 

 
 

 Select Table: Products from the Tables/Queries drop-down menu. 
 Add the ProductName field: 
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 Click Next. 
 Select the Choose from a list option button: 

 

 
 

 Click Next. 
 Type Products subreport as the name of the subreport. SAMPLE
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 Click Finish: 
 

 
 

 With the main report in Design view, move and resize the Products subreport 
as shown below: 
 

 
 

 Change the Report Header for the Products subreport to Products: 
 

 
 

 Right-click on the Products subreport label. 
 From the pop-up menu, select Cut. 
 Click the Save button.  Save the report as Categories and Products. 
 Click OK. 
 Close the report. 
 
 

SAMPLE
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Creating a Report with Two Subreports 
 Click Reports in the Objects pane. 
 Click the New button on the database window. This opens the New Report 

dialog box. 
 Select Report Wizard. 
 Click OK. 
 Select Table: Categories from the Tables/Queries drop-down menu. 
 Add the CategoryName and Description fields: 

 

 
 

 Select Table: Products from Tables/Queries drop-down menu. This will be 
the first subreport. 

 Add the ProductName field. 
 Select Table: Order Details from Tables/Queries drop-down menu. This will 

be the second subreport. 
 Add the UnitPrice, Quantity, and Discount fields: 

 

 
 

 Click Next. 
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 Select the by Categories view option: 
 

 
 

 Click Next. 
 Select the Quantity grouping level from the Do you want to add any 

grouping levels dialog box: 
 

 
 

 Click Next.  Select the UnitPrice field to sort, and click on the Ascending 
button: 
 SAMPLE
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 Click Next.  Leave the default settings: 
 

 
 

 Click Next.  Select the Corporate report style: 
 

 
 

 Click Next. 
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 Type Categories Sample for the report name. 
 Click Finish. 
 Close the report. 
 Close the Northwind database. 
 
 

Working with Report Snapshots 
 

 Open the Northwind database. 
 In the displayed Main Switchboard dialog box, click on the Display Database 

Window button. 
 Click Reports in the Objects pane. 
 Click on the Categories and Products report. 
 From the main menu, select File > Export. 
 Locate your Access 2003 Intermediate Samples folder. 
 Select Snapshot Format from the Save as type drop-down menu: 

 

 
 

 Name the file Categories and Products Snapshot. 
 Click Export. 

 
Note: To see a sample of this snapshot report, open Categories and Reports 
Snapshot Sample.snp in your Access 2003 Intermediate Samples folder. 
 

 Close the Northwind database. 
 
 

Developing Data Access Pages 
 
 

 Using the New Data Access Page Wizard 
 Open the Northwind database. 
 In the displayed Main Switchboard dialog box, click on the Display Database 

Window button. 
 Select Pages in the Objects pane.  Click the New button. 
 Select Page Wizard.  Select Customers from the drop-down menu. 

SAMPLE
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 Click OK: 
 

 
 

 Select all fields from the Available Fields list: 
 

 
 

 Click Next. 
 Select CompanyName for the grouping level: 

 

 
 

 Click Next. 
 From the sort order drop-down menu, select CustomerID. 
 Set the sort order as Ascending: 

 

SAMPLE
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 Click Next. 
 Type Customers as the name for the data access page. 
 Click Finish: 

 

 
 

 This opens the Customers data access page in Design view. 
 Click the Save button. Save the file as Customers.htm in your Access 2003 

Intermediate Samples folder. 
 Click Save. If you see a dialog box asking you if you want to set the folder as 

the default location for data access files, click No. 
 Close the Customers data access page. 

 
Note: To see a sample of what the Customers data access page should look 
like, open the Customers Sample.htm in your Access 2003 Intermediate 
Samples folder. 

 
 

 Defining a Data Source for a Stand-Alone Data Access Page 
 Close the Northwind database, then from the main menu, select File > New.  

The New File Task Pane appears. 
 Click the Blank data access page link on the New File Task Pane.  This opens 

the Select Data Source dialog box. 
 Double-click +Connect to New Data Source: 

 

SAMPLE
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 This opens the Data Connection Wizard dialog box. 
 Select the desired data source to which you wish to connect.  Ask your instructor 

if you are unsure as to which data sources are available: 
 

 
 

 Click Next. 
 Select the desired data Provider. 
 Click Next. 
 Select the desired Connection properties. 
 Click OK.  This opens another dialog box: 

 

 
 

SAMPLE
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 Click Next.  Type Sample.odc as a name for the new Data Connection: 
 

 
 

 Click Finish. 
 Close the data access page. 
 
 

 Creating Stand-Alone Data Access Pages 
 From the main menu, select File > New.  The New File Task Pane appears. 
 Click the Blank data access page link. 
 Select Sample.odc. 
 Click Open. 
 This opens a blank Data Access Page: 

 

 
 

 From the main menu, select View > Field List. 
 This opens the Field List task pane which displays a listing of available table 

and query fields to add to the Data Access Page. 

SAMPLE
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 Double-click on Customers to expand the menu, and select the 
CompanyName, ContactName, and ContactTitle fields from the Field List 
pane. 

 Click Add To Page to add the fields to the blank page: 
 

 
 

 This opens the Layout Wizard: 
 

 
 

 Select the Columnar layout. 
 Click OK. 
 Close the data access page without saving the changes. 
 SAMPLE
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Working with PivotTables and PivotCharts 
 
 

Creating Pivot Tables and Pivot Charts 
 
 

Using PivotTables and PivotCharts 
 Open the Northwind database. 
 In the displayed Main Switchboard dialog box, click on the Display Database 

Window button. 
 Click Queries in the Objects pane. 
 Double-click the Quarterly Orders by Product query to open it in Datasheet 

view. 
 From the main menu, select View > PivotTable View. 
 From the PivotTable Field List toolbox, drag and drop the Product Name field 

on the row fields portion of the worksheet: 
 

 
 

 Drag and drop the OrderYear field on the filter fields portion of the 
worksheet: 
 

 
 

 Drag and drop the CustomerID field on the column fields portion of the 
worksheet: 
 

 
 

 Drag and drop the Qtr 1 field on the detail fields portion of the worksheet: 
 

 
 

 Click the Product Name drop-down menu. 
 Deselect the All check box. 
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 Check the Alice Mutton, Chai, and Chang boxes: 
 

 
 

 Click OK. 
 Click the CustomerID drop-down menu. 
 Deselect the All check box. 
 Check the ALFKI, BERGS, and BONAP boxes: 

 

 
 

 Click OK. 
 Save the changes. 
 From the main menu, select View > PivotChart View. 
 Drag and drop the Qtr 1, Qtr 2, Qtr 3, and Qtr 4 fields on the data fields 

portion of the worksheet: 
 

 
 

 Click on the chart. 
 From the main menu, select PivotChart > Chart Type. 
 Click the Type tab. 
 Change the chart type to a 3D Column chart: 
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 Close the Properties dialog box. 
 Save the changes. 
 Close the Quarterly Orders by Product pivot chart worksheet. 
 Close the Northwind database. 
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Importing and Exporting 
 
 

Linking to External Data Sources 
 
 

Linking to Text Files 
 Open the Northwind database. 
 In the displayed Main Switchboard dialog box, click on the Display Database 

Window button. 
 Click Tables in the Objects pane. 
 Click the New button. 
 Select Link Table. 
 Click OK: 

 

 
 

 From the Files of type drop-down menu, select Text Files (*.txt; *.csv; 
*.tab; *.asc). 

 Locate your Access 2003 Intermediate Samples folder. 
 Select the Territories.txt file. 
 Click Link. 
 Click the Delimited option button. 
 Click Next: 
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 Click the Tab option button. 
 Check the First Row Contains Field Names check box: 

 

 
 

 Click Next. 
 Select the TerritoryID column. 
 From the Data Type drop-down menu, select Long Integer: 
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 Click Next. 
 Name the linked table Territories. 
 Click Finish. 
 Click OK on the confirmation pop-up dialog box. 
 
 

Linking to Microsoft Excel Spreadsheets 
 Click Tables in the Objects pane. 
 Click the New button.  This opens the New Table dialog box. 
 Select Link Table. 
 Click OK.  This opens the Link dialog box. 
 From the Files of type drop-down menu, select Microsoft Excel (*.xls). 
 Locate your Access 2003 Intermediate Samples folder. 
 Select the sales.xls file. 
 Click Link. 
 This opens the Link Spreadsheet Wizard: 
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 Click on the Finish button. 
 Click OK on the confirmation pop-up dialog box. 
 
 

Linking to HTML Files 
 Click Tables in the Objects pane. 
 Click the New button.  This opens the New Table dialog box. 
 Select Link Table. 
 Click OK.  This opens the Link dialog box. 
 From the Files of type drop-down menu, select HTML Documents (*.html; 

*.htm). 
 Locate your Access 2003 Intermediate Samples folder. 
 Select the Cheltenham Courseware.htm file. 
 Click Link. 
 This opens the Link HTML Wizard: 
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 Click the Finish button. 
 Click OK on the confirmation pop-up dialog box. 
 
 

Linking to Other Access Databases 
 Click Tables in the Objects pane. 
 Click the New button.  This opens the New Table dialog box. 
 Select Link Table. 
 Click OK.  This opens the Link dialog box. 
 From the Files of type drop-down menu, select Microsoft Office Access (*.mdb; 

*.mda; *.mde). 
 Locate your Access 2003 Intermediate Samples folder. 
 Select the Data.mdb file. 
 Click Link.  This opens the Link Tables dialog box: 

 

 
 

 Select the Expenses Report table. 
 Click OK. 
 Close the Northwind database. 
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Importing Data into Access 
 

 Open the Northwind database. 
 In the displayed Main Switchboard dialog box, click on the Display Database 

Window button. 
 Click Tables in the Objects pane. 
 Click the New button. 
 Select Import Table: 

 

 
 

 Click OK. 
 This opens the Import dialog box. 
 From the Files of type drop-down menu, select Text Files (*.txt; *.csv; 

*.tab; *.asc). 
 Locate your Access 2003 Intermediate Samples folder. 
 Select the EmployeeTerritories.txt file. 
 Click Import. 
 Click the Delimited option button. 
 Click Next: 
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 Click the Tab option button. 
 Check the First Row Contains Field Names check box. 
 Click Next. 
 Click the In a New Table option button: 

 

 
 

 Click Next. 
 Accept the defaults and click Next: 
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 Select the No primary key option button: 
 

 
 

 Click Next. 
 Name the new imported table EmployeeTerritories. 
 Click Finish: 
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 Click OK on the confirmation pop-up dialog box. 
 Close the Northwind database. 
 
 

Importing Data into Access 
 
 

Importing from Excel Files 
 Open the Northwind database. 
 In the displayed Main Switchboard dialog box, click on the Display Database 

Window button. 
 Click Tables in the Objects pane. 
 Click the New button.  This opens the New Table dialog box. 
 Select Import Table. 
 Click OK.  This opens the Import dialog box. 
 From the Files of type drop-down menu, select Microsoft Excel (*.xls). 
 Locate your Access 2003 Intermediate Samples folder. 
 Select the sales.xls file. 
 Click Import. 
 Click Finish to complete the wizard. 
 Click Yes on the warning dialog box. 
 Click OK on the confirmation pop-up dialog box. 
 
 

Importing from Other Access Databases 
 Click Tables in the Objects pane. 
 Click the New button. This opens the New Table dialog box. 
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 Select Import Table. 
 Click OK.  This opens the Import dialog box. 
 From the Files of type drop-down menu, select Microsoft Office Access (*.mdb; 

*.adp; *.mda; *.mde; *.ade). 
 Locate your Access 2003 Intermediate Samples folder. 
 Select the Data.mdb file. 
 Click Import.  This opens the Import Objects dialog box. 
 Click on the Tables tab. 
 Select the Expenses Report object to import. 
 Click OK: 

 

 
 

 Close the Northwind database. 
 
 

Exporting Data from Access 
 
 

Exporting to Files 
 Open the Northwind database. 
 In the displayed Main Switchboard dialog box, click on the Display Database 

Window button. 
 Select the Customers table to export. 
 From the main menu, select File > Export. This opens the Export Table To 

dialog box. 
 From the Save as type drop-down menu, select Microsoft Excel 97-2003 (*.xls). 
 Locate your Access 2003 Intermediate Samples folder. 
 In the File name field, type Customers.xls. 
 Click Export. 
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Exporting to Access Databases 
 Select the Customers table to export. 
 From the main menu, select File > Export.  This opens the Export Table To 

dialog box. 
 From the Files of type drop-down menu, select Microsoft Office Access (*.mdb; 

*.adp; *.mda; *.mde; *.ade). 
 Locate your Access 2003 Intermediate Samples folder. 
 Select the Data.mbd file. 
 Click Export.  This opens the Export dialog box: 

 

 
 

 Click OK. 
 Close the Northwind database. 
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Building Expressions 
 
 

Using the Expression Builder 
 
 

Using the Expression Builder in Queries 
 Open the Northwind database. 
 In the displayed Main Switchboard dialog box, click on the Display Database 

Window button. 
 Click Queries in the Objects pane. 
 Open the UnitPrice * 10 query in Design view. 
 Click in a blank field on the query grid. 
 Click the Build button on the Query Design toolbar: 

 

 
 

 In the Expression Builder, double-click the Functions folder. 
 Click Built-In Functions. 
 Click Text. 
 Double-click the Left function to add it to the Expression Builder pane: 

 

 
 

 Replace «stringexpr» with [ProductName]. 
 Replace «n» with 1: 
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 Click OK. 
 Rename the column from Expr2 to Rolodex. 
 Change the sort order to Ascending: 

 

 
 

 Run the query. 
 Save the changes. 
 Close the UnitPrice * 10 query. 
 
 

Using the Expression Builder in Forms 
 Click Forms in the Objects pane. 
 Open the Categories form in Design view. 
 Double-click on any control in the form. 
 Click the Data tab. 
 Click the ellipses next to the Control Source field: 
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 This opens the Expression Builder. 
 Build an expression using an item from the field list.  Experiment!: 

 

 
 

 Click OK. 
 Notice the format of the Control Source expression: 

 

 
 

 View the form to see the results. 
 Close the form without saving the changes. 
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Using the Expression Builder in Reports 
 Click Reports in the Objects pane. 
 Open the Categories and Products form in Design view. 
 Double-click on a control in the report. 
 Click the Data tab. 
 Click the ellipses next to the Control Source field.  This opens the Expression 

Builder. 
 Build an expression using an item from the field list.  Experiment! 
 Click OK. 
 View the report to see the results. 
 Close the report without saving the changes. 
 Close the Northwind database. 
 
 

Using Common Built-in Functions 
 
 

Using Date/Time Functions 
 Open the Northwind database. 
 In the displayed Main Switchboard dialog box, click on the Display Database 

Window button. 
 Click Reports in the Objects pane. 
 Open the Categories and Products report in Design view. 
 Click the Text Box button on the Toolbox toolbar: 

 

 
 

 Add a Text Box control to the Page Footer section of the report. 
 Label the new control DATE: 
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 Double-click on the unbound portion of the DATE control. 
 Click the Data tab. 
 Click the ellipses next to the Control Source field: 

 

 
 

 Double-click Functions. 
 Click Built-In Functions. 
 Click Date/Time. 
 Double-click Date to add it to the control: 

 

 
 

 Click OK. 
 Close the dialog box. 
 Save the changes to the Categories and Products report. 
 Close the report. 
 
 

Using Financial Functions 
 Click Reports in the Objects pane. 
 Open the Categories and Products report in Design view. 
 Click the Text Box button on the Toolbox toolbar: 
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 Add a Text Box control to the Page Header section of the report. 
 Double-click on the control. 
 Click the Data tab. 
 Click the ellipses next to the Control Source field.  This opens the Expression 

Builder. 
 From the field list, select Functions > Built-In Functions > Financial. 
 Scroll through the list of Financial functions.  Try using the various functions.  

Experiment! 
 Click OK. 
 Close the report without saving any changes. 
 Close the Northwind database. 
 Exit Access 2003. 
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