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Building a Web Site 
 
When you have completed this learning module you will have seen how to: 

 Create a New Web Site 
 Create a Web Site with a Wizard 
 Create a Web Site using a Template 
 Use the Web Location Options area 
 Choose Web Hosting Service Providers 
 Choose ISP Service Providers 
 Use a Personal Web Server 
 Create a new Page using a Template 
 Check Spelling 
 Check Hyperlinks 
 Set Tasks 
 Set Permissions 
 
 

Using a Wizard or Template 
 

Creating a New Web Site 
 When a web page is created onto a Web server, it is accessible to external 

viewers, via the Internet or an Intranet.   
 The computer that the page is created on must have the Hypertext Transfer 

Protocol (HTTP) server software installed on it. 
 This allows you to create and edit documents on the web from any location, 

and will remove the steps of having to download, edit, and then upload the 
page every time. 

 On the other hand, when a web page is created directly onto a local hard disk 
or network drive, it can be published at a later point by using the Publish 
Web feature. 
 
Note: This procedure will not allow you to test certain features. 
 

 This is a very good way to create a web page for a first time user. 
 When a web site is created, the location of the files for the web that are saved 

must be specified, either to a local hard disk, network drive, or a Web 
server. 

 If saving to a Web server, this will be a web site address that viewers can 
enter into their browsers to view the page. 

 If saving to a local web for testing, and only if Web server software like 
Microsoft PWS is running on the computer, specify the server address as 
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http://localhots/ or http://127.0.0.1.  The web site will be functional 
immediately when web creation begins. 

 If saving to a local web other than Microsoft PWS, the FrontPage Server 
Extensions will have to be installed on the computer being used for the web 
site creation. 

 If saving to a Web hosting service, the service will provide the server address 
that the web will be designed on.  Most hosting services will provide the 
FrontPage server extensions with the hosting package. 

 If using a Web server not supported by FrontPage server extensions, or 
saving to a hard disk, the web pages can be exported to the Web server with 
the Publish feature. 

 

Creating a Web Site with a Wizard 
 From the main menu, choose File > New > Page or Web to open the New 

Page or Web panel: 
 

 
 

 Select Web Site Templates to open the Web Site Templates dialog box: 
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There are four web site Wizards available to use: 

 The Corporate Presence Wizard. 
 The Discussion Web Wizard. 
 The Database Interface Wizard 
 The Import Web Wizard. 
 

 The Corporate Presence Wizard allows you to create a full web site, generally 
for a smaller company: 
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This wizard moves through a series of steps which include: 

 Selecting what appears on the opening web site page. 
 Choosing the contact information. 
 Selecting a theme for the site from an existing list: 
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 Once all steps are completed, the final wizard will allow you to launch the Tasks 
view in a new window for the newly created web site, allowing you to view the 
total pages to be edited: 
 

 
 

 
 

 Double click on a task to open the Task Details dialog box: 
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 Click the Start Task button to open the page for editing: 
 

 
 

 
 

 The Discussion Web Wizard allows you to create an area for viewers to 
engage in a forum on various topics: 
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This wizard moves through a series steps which include: 

 Selecting the theme for the web pages. 
 Choosing how information is listed. 
 Using frames within the documents: 

 

 
 

 Once done, click the Finish button, and the discussion page will open in a new 
window, allowing you to begin editing: 
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 The Database Interface Wizard allows you to connect to an outside database 
so viewers of the Web site can do searches that are answered from the 
database: 
 

 
 
Note: This Wizard needs the FrontPage server extensions installed in order 
to work: 
 

 
 

This wizard moves through a series steps which include: 

 Setting the database name. 
 Selecting the main fields to be created. 
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 Setting which pages to create: 
 

 
 

 Once the database wizard is done, click Finish and the database will open in a 
new window, showing the database index page, and any other pages selected to 
be created: 
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 The last wizard is the Import Web Wizard.  It allows you to create a web site 
containing documents from a local directory or an outside system: 
 

 
 

 Once a source has been selected, click the Next button to open the next wizard 
window: SAMPLE
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 Select which files to remove from the import, and click the Next button to open 
the last wizard window: 
 

 
 

 Click the Finish button, and a new window will open. 
 Click the Folders button in the Views panel  This will open to show the web 

files that were imported to the new web site being created: 
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Creating a Web Site using a Template 
 From the main menu, choose File > New > Page or Web to open the New 

Page or Web task pane. 
 Select Web Site Templates to open the Web Site Templates dialog box: 

 

 
 

 The One Page Web template allows you to create an empty home page, that 
will open in a new window: 
 

 
 

 
 

 

 The Customer Support Web template allows you to create a full customer 
support web site, without having to use a wizard: 
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 Simply double click on a page to open and edit. 
 The Empty Web template allows you to create exactly that, a web site with no 

content at all.  It will only create a directory that all pages, once created, are 
stored in: 
 

 
 

 The Personal Web template allows you to create a full personal web site, 
without having to use a wizard: 
 

 
 

 Simply double click on a page to open and edit. 
 The Project Web template allows you to create a way for multiple members of 

a team to touch base. 
 All information that is being created by each individual of the team for a 

project, can be stored here as well: 
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 The main use for this template is for an Intranet. 
 The SharePoint-based Team Web Site template allows you to create a more 

intense collaborative site that has a shared document area, contact and task 
lists, calendar, and more. 

 This template can only be created on a server that has SharePoint (Office 
Web) server extensions installed.  Otherwise, a warning dialog box will open: 
 

 
 
 

Web Location Options 
 

Using the Web Location Options area 
 The Web Site Templates dialog box allows you to select the appropriate 

location that the new site will be hosted from. 
 From the main menu, choose File > New > Page or Web to open the New 

Page or Web task pane. 
 Select Web Site Templates to open the Web Site Templates dialog box. 
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 In the Options area, select the directory to where the new web site will be 
stored: 
 

 
 

 Typically, FrontPage will automatically offer a storage directory, a name for the 
new web site, as well as a home page called index.htm within the root index of 
the newly created web site. 

 If the Add to current Web checkbox is selected, the newly created web site, 
along with its new home page index.htm, will be added to the currently open 
site. 

 If the new site also has a home page named index.htm, one of the pages will 
be deleted, so it is best to leave the Add to current Web checkbox unselected 
as to not lose any information. 

 

Choosing Web Hosting Service Providers 
 There are a variety of web hosting providers, and with that, they need to be 

compared to know which will provide the needed requirements on a per-user 
basis. 
 
Pricing - Look at this closely, as some plans can include site design, high-speed 
connection and more. 
 
Disk Space - The Disk space tells you how much space you will need with all 
pages and any multimedia files contained in the web site.  To get a better idea 
of how much space will be required, create a disk-based web site closely 
matched to what the final product will be.  The space taken on the disk will tell 
you the space you will need from the provider. 
 
Connection Speed – This can be quite different between providers, but the 
best to use are T-1 and T-3. Keep in mind that the speed offered is from the 
hosting provider to the Internet, not from the computer that the web site was 
created on to the hosting provider. 
 
Traffic - Watch the traffic that the new web site receives.  If more traffic occurs 
than originally specified to the web hosting provider, extra charges will apply. 
 
FrontPage Server Extensions - Make sure that the web hosting provider will 
include the FrontPage server extensions, and not charge separately for 
them, as well as have the most up-to-date version of the extensions. 
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Domain Name Hosting - Some service providers can provide better pricing on 
domain names, rather than going through the older web name registries. 
 
Email Accounts/Mailing Lists – Look into how many email accounts are 
provided with the hosting, most will include at least 1 account, depending on the 
disk space being taken by the site. 
 
FTP - The Publish feature in FrontPage is what is used to upload the web page 
file onto the Internet, so confirm that at least one FTP account is included from 
the hosting provider. 
 
Server Security - This is an important feature to have if the new site requires 
portions to be placed within a secure server for transmitting any data.  Confirm 
that the provider can offer this. 
 
E-commerce - If creating a web site offering products for online purchasing, 
hosting providers will typically have this capability, but for a higher package 
price.  The hosting provider can also aid in creating a merchant account, for 
accepting credit cards online. 
 
CGI - CGI (Common Gateway Interface) is the main scripting technology 
behind web programming.  If the hosting provider is on Unix servers, it can 
provide a CGI script directory, but if it is on NT servers, they might not be 
available. 
 
Access and SQL - The hosting provider must be able to support database 
serving if the web site is database-driven.  Most providers will provide for both 
Access and SQL databases, but it is important to check. 
 
Statistics - Most hosting providers can provide information on the number of 
times the site is viewed, who is viewing the site, and the click rate on any 
banners ads or downloads on the site.  If budgeting and marketing campaigns 
will be based from the web site, make sure that the correct information and 
reports can be tracked and reported on. 
 
Backups - It is very important to make sure that the hosting provider being 
used is backing up web sites on a regular basis.  This will cut down on any 
frustration for the viewer if information is not updated on time.  If is also good 
for keeping accurate information captures for reports. 

 

Choosing an ISP 
 An ISP (Internet Service Provider) is mainly concerned with the user that is 

connected to the Internet, not the web that is being hosted on the Internet.  
However, using an ISP provider allows you to use only one provider for all your 
needs, and can be a better solution for smaller companies with smaller sites. 
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Using a Personal Web Server 
 When a web site is created as a disk-based Web on a hard-drive, testing it in a 

minimal fashion without having to have an outside hosting provider can be done 
with a personal web server. 

 If using a NT4 or Windows 2000 environment, access to the Internet 
Information Server (IIS) is probably already provided. 

 If using a NT4 environment without access provided, the NT4 Option Pack can 
install a version of IIS, located on the Microsoft web site. 

 If using a Windows 95 or Windows 98 environment, the NT4 Option Pack 
can install a version of IIS, located on the Microsoft web site. 

 If using a Windows 98 or Windows 98 Second Edition environment, the Windows 
Installation CD can install a version of IIS. 

 
 

Designing a Web Site 
 

Creating a new Page using a Template 
 Individual Web pages can be created through the Page Templates dialog box, 

and formatted with the Page Properties dialog box. 
 From the main menu, choose File > New > Page or Web to open the New 

Page or Web task pane. 
 Select Page Templates from the New from Template area to open the Page 

Templates dialog box: 
 

 
 

 Select the Frames Pages tab to view various templates that already contain 
frames: 
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 Select the Style Sheets tab to view various templates that already contain a 
variety of set styles: 
 

 
 

 Once a template is selected, it will open in a new window. 
 From the main menu, choose File > Properties to open the Page Properties 

dialog box 
 
OR right-click anywhere on the page, and from the pop-up menu, select Page 
Properties to open the Page Properties dialog box: 
 

 
 

 Use this dialog box to alter the name of the page, the location, the color, 
and any other required changes. 
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 Save the page once any change is done. 
 
Note: To view the Background tab within the Page Properties the web will 
have to be closed.  From the main menu choose File > Close Web to close the 
web settings and to disable any themes or style sheets that may be in place. 

 

Checking Spelling 
 A simple spell check on individual pages can be done.  From the main menu, 

choose Tools > Spelling to open the Spelling dialog box: 
 

 
 

 Spelling should be checked across multiple pages of an entire web site, to 
make sure that all spelling and choices are the same. 

 Open the web site in any view except for Page. 
 From the main menu, choose Tools > Spelling to open the Spelling dialog 

box: 
 

 
 

 Select Entire web under the Check spelling of area. 
 Click Start: 
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 This allows you to do a Global spell check of all pages within the web site 
created.  Select the Add a task for each page with misspellings checkbox to 
remind you or to assign the task to another person to correct the misspellings. 

 Double click on the file listed in the dialog box to open the page and correct any 
misspellings. 

 

Checking Hyperlinks 
 From the main menu, choose View > Toolbars > Reporting to open the 

Reports toolbar. 
 From the Reports toolbar, select the Verify Hyperlinks icon:  

 

 
 

 
 
OR from the main menu, choose Tools > Recalculate Hyperlinks to update 
all views of the web site as well as the multiple items within the web site:  
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Note:  You must be online to use either method. 
 

 The Verify Hyperlinks icon allows you to have FrontPage check any external 
hyperlinks connected to the web site.  You can verify hyperlinks on all pages, or 
for one selected page. 

 The result will show in the Broken Hyperlinks report, as Unknown, Broken or 
OK. 

 The Recalculate Hyperlinks command allows you to update all views of the 
web site, as well as update any text indexes created if there is a search 
component in the web site.  This command will regenerate all of the Include 
components in the web site, and will update all Web content that is connected to 
those components. 

 

Setting Tasks 
 Open the page in the Page view. 
 From the main menu, choose Edit > Tasks > Add Task 

 
OR from the main menu, choose File > New > Task to open the New Task 
dialog box: 
 

SAMPLE



Page 27 – Microsoft FrontPage XP - Intermediate Level Manual 

FOR USE AT THE LICENSED SITE(S) ONLY 
 Cheltenham Courseware Ltd. 1995-2010 www.cheltenhamcourseware.com 

 
 

 The Associated with line shows which page the task will be connected to.  
When selecting the Start Task command, it will automatically open the 
connected page. 

 Enter the required information, and click OK. 
 If you are in the Tasks, Folders, Navigation, Hyperlinks or Reports view, 

select the page that the task needs to be connected to. 
 Right click on the selected page, and from the pop-up menu that appears, select 

Add Task. 
 This will open the Add Task dialog box. 
 Enter the required information and click OK. 
 

Setting Permissions 
 Permissions can be set to allow various users access to administer, author or 

simply browse a web site. 
 From the main menu, choose Tools > Server > Permissions to open the 

Permissions dialog box. 
 Browse - Allows users to access the web pages through an internet browser, 

and view the pages.  Alterations of any kind cannot be made by a browser. 
 Author and Browse - Allows certain users to create and edit any content on 

the web site, but they cannot add, delete or manage the web site and pages in 
any way. 

 Administer, Author and Browse - Allows users to have full access to the web 
site and all the administration that is connected to the site.  This user can add 
and delete web pages, and set any web permissions and configurations 
themselves. 
 
Note: Only the original creator of the web site can restrict other 
administrators to specific web sites. 
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Review Questions 
 
How would you: 

 Create a New Web Site? 
 Create a Web Site with a Wizard? 
 Create a Web Site using a Template? 
 Use the Web Location Options area? 
 Choose Web Hosting Service Providers? 
 Choose ISP Service Providers? 
 Use a Personal Web Server? 
 Create a new Page using a Template? 
 Check Spelling? 
 Check Hyperlinks? 
 Set Tasks? 
 Set Permissions? 
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Frames 
 
When you have completed this learning module you will have seen how to: 

 Use Frames 
 Use a Frame Template 
 Edit Framesets 
 Create Custom Framesets 
 Use Target Frames 
 Create Custom Frameset Templates 
 Place Pages into a Frameset 
 Use Static Frames 
 Remove a Frameset 
 Use DHTML Layout Positioning 
 Use Absolute Positioning for Layout 
 Use Relative Positioning for Layout 
 Use the Wrap Text Style 
 Create Page Transitions 
 Create Collapsible Outlines 
 Set Z-Order Layering 
 Collect Elements 
 
 

Working with Frames 
 

Using Frames 
 By placing frames on a page, you are placing two or more windows on the 

same screen, and the viewer can have control over none, some or all of the 
frames. 

 Frames can hold other frames, and pages inside a frame. Frames can also refer 
to alternate pages other than what can be immediately seen. 

 Using frames allows you to show static as well as dynamic elements on a page. 
 Static elements are visible whatever the viewer may do, and dynamic 

elements are altered based on a viewer’s input. 
 Using frames within a page is a useful tool to keep a viewer oriented to the 

various pages within a web site.  A viewer can easily move through a site if 
alternate pages are listed in a static frame somewhere to the side, top or bottom 
of the page. 
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Using a Frame Template 
 From the main menu, choose File > New > Page or Web to open the New 

Page or Web task panel. 
 Select Page Templates to open the Page Templates dialog box. 
 Select the Frames Pages tab: 

 

 
 

 The Banner and Contents template allows you to create a page that has a 
banner frame at the top of the page, a contents frame on the left of the page, 
and a main frame: 
 

 
 

 
 

 The Contents template allows you to create a frame for links to the left of the 
page, allowing the viewer to select and alter the page in the main view: 
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 The Footer template allows you to create a frame for links on the bottom of the 
page, allowing the viewer to select and alter the main view: 
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 The Footnotes template allows you to create a footnote area on the bottom of 
the page that the viewer can change with links on the main page: 
 

 
 

 
 

 The Header template allows you to create a frame for links at the top of the 
page, allowing the viewer to select and alter the main view: 
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 The Header, Footer and Contents template allows you to create frames for 
links at the top, bottom and left side of the page, allowing the viewer to select 
and alter the main view: 
 

 
 

 
 

 

 The Horizontal Split template allows you to create a page with top and bottom 
frames that are independent of each other: 
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 The Nested Hierarchy template allows you to create a page where there are 
links in the frame on the left, the link destinations appear in the frame at the 
top, and the destination pages are in the bottom frame: 
 

 
 

 
 

 

 The Top-Down Hierarchy template allows you to create a page where the links 
are listed in the top frame, the link destinations are in the middle frame, and the 
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destination pages are in the bottom frame: 
 

 
 

 
 

 The Vertical Split template allows you to create a page with left and right 
frames that are independent of each other: 
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Editing Framesets 
 A Frameset is where multiple frames appear in the same page. 
 Click on the page within a frame to edit the text within the frame. 
 An active frame has a dark blue border surrounding its edges. 
 Place the cursor on a frame edge, then click and drag to alter the size of the 

frame. 
 Click on the Frames page HTML button at the bottom of the window to view 

the frameset file HTML information: 
 

 
 

 Click on the No Frames button at the bottom of the window to edit text in a 
non-frame supporting browser.  Alter the default warning message, and it will be 
saved with the frameset file: 
 

 
 

 
 

Creating Custom Framesets 
 Begin by creating a main page from a frame template, along with the 

remainder of required pages. 
 If using Horizontal Split template, the frameset can be modified to have the 

links in the frame on the top of the page alter the contents in the bottom frame, 
and the links in the bottom frame alter the contents in the frame on top: 
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 Right-click on the top frame, and from the pop up menu that appears, select 
Frame Properties, take note of the name of the frame that was supplied from 
the template, and click Cancel: 
 

 
 

 Right-click on the bottom frame, and from the pop-up menu that appears, select 
Frame Properties. 

 Take note of the name of the frame that was supplied from the template, and 
click Cancel: 
 

 
 

To split the frame: 

 Click to place the cursor inside a frame. 

SAMPLE



Page 38 – Microsoft FrontPage XP - Intermediate Level Manual 

FOR USE AT THE LICENSED SITE(S) ONLY 
 Cheltenham Courseware Ltd. 1995-2010 www.cheltenhamcourseware.com 

 From the main menu, choose Frames > Split Frame to open the Split Frame 
dialog box: 
 

 
 

 Select an option and a small preview of the split will appear on the right side 
of the dialog box. 

 Once done, click OK: 
 

 
 

 In the bottom frame, click the Set Initial Page button to open the Insert 
Hyperlink dialog box: 
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 Assign the other pages that were built to various hyperlinks as required within 
the frames of the new page. 

 

Using Target Frames 
 To have a truly static frame, confirm that it is not the target frame for a 

hyperlink in the web. 
 From the main menu, choose Insert > Hyperlink to open the Insert 

Hyperlink dialog box. 
 Click the Target Frame button to open the Target Frame dialog box: 

 

 
 

 This dialog box allows you to easily create image-based links with the 
necessary target frame: SAMPLE
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 Select a name from the Common targets list, and its preset template name will 
appear in the Target setting field. 
 
New Window – This will place the link into a frame and when the link is 
selected, it will open in a new window. 
 
Same Frame – This will place the link into the selected frame, and when the 
link is selected, it will open in the same area that the link was located, and the 
frame layout is not altered. 
 
Parent Frame – This will place the link into the selected frame, and when the 
link is selected, it will open in the same area that the link was located and will 
reset the browser window. 
 
Whole Window – When the link is selected, it will open to replace the entire 
page window, taking the place of the original frameset. 

 

Creating Custom Frameset Templates 
 If a particular frame layout is a favorite, and often used, the file can be saved as 

a template for future use. 
 Right-click anywhere on the page and from the pop up menu that appears, 

select Page Properties to open the Page Properties dialog box. 
 Name the template in the Title field. 
 Click OK. 
 From the main menu, choose File > Save As to open the Save As dialog box. 
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 From the Save as type drop down menu, choose FrontPage Template: 
 

 
 

 Click Save to open the Save As Template dialog box: 
 

 
 

 Edit the Title and Name fields as required. 
 Enter into the Description field a brief description of the template being saved. 
 The description must be added to the template, as it shows in the Page 

Templates dialog box when selecting the template. 
 If the Save Template in Current Web checkbox is selected, the template will 

only be available when working on this particular web series. 
 Once done, click OK. 
 

Placing Pages into a Frameset 
 The pages to be placed into an existing frameset must be created before they 

can be placed. 
 Open the frameset that the pages will be inserted into. 
 From the main menu, choose Insert > Hyperlink to open the Insert 

Hyperlink dialog box. 
 Insert a link to the page to be inserted into the required frame. 
 In the Insert Hyperlink dialog box, click the Target Frame button to open the 

Target Frame dialog box. 
 Select the required target frame. 
 If required, select the Set as page default checkbox. 
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 Click OK to close the Target Frame dialog box. 
 Click OK to close the Insert Hyperlink dialog box. 
 The link to the inserted page will open the new page within the selected frame. 
 

Using Static Frames 
 Using a static frame allows you to have an area on the page that cannot be 

altered by the viewer in any way. 
 Open the first page of a frame, that which shows when the frameset is opened. 
 Right-click and from the pop-up menu that appears, select Page Properties to 

open the Page Properties dialog box. 
 Set a default target frame that is not the frame that the page is currently 

showing in. 
 All pages opened from the original page links will open in the target frame, and 

not the frame with the links. 
 The content of the static frame is now set, and will not alter. 
 

Removing a Frameset 
 From the main menu, choose View > Folders to open the folders list 

OR click on the Folders icon in the View panel to open the folders list. 
 

 Select the frameset file, and from the main menu, choose Edit > Cut 
OR press the Delete key on the keyboard. 
 
Note: If a frameset is removed, all frame target entries or links that are 
connected to the removed frameset must also be removed. 

 
 

Positioning Content 
 

Using DHTML Layout Positioning 
 Positioning code created through Cascading Style Sheets within the DHTML 

toolkit works mainly with Internet Explorer 4 and 5 browsers. 
 Any Netscape browser understands the code, but cannot properly execute the 

layout. 
 

Using Absolute Positioning for Layout 
 Absolute positioning allows you to set an element onto a page in relation to 

the upper-left corner of the page. 
 X and Y coordinates are used, and the upper-left pixel corner is set at 0,0. 
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 This positioning is called absolute because the element’s position cannot be 
altered. 

 This allows you to create a page where the element will not move no matter 
what is done with the page in terms of resizing, or even with the size of the 
screen that the viewer is using. 

 Insert the required image onto the page, typing the caption for the image as 
well.  They do not need to be in the required placement yet, as they will be 
moved there. 

 Click on the image to select it: 
 

 
 

 From the main menu, choose Format > Position to open the Position dialog 
box: 
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 Select the Absolute icon. 
 Use the Left and Top drop down menus to set the coordinates of the upper-left 

corner of the image. 
 The Width and Height drop down menus will contain the dimensions of the 

image already, so there is no need to alter them. 
 Click OK: 

 

 
 

 The image may be sitting on top of the entered caption, but this will be fixed. 
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 If the image is not sitting exactly where you want it to be, there is no need of 
continually going back to the Position dialog box and altering the pixels one by 
one. 

 Simply select the image and drag to the required location. 
 Select the caption text: 

 

 
 

 From the main menu, choose Format > Position to open the Position dialog 
box. 

 Select the Absolute icon. 
 The caption text is now an absolute element. 
 Using the handles around the caption, alter the shape of the text as required, 

and drag to alter its positioning: 
 

 
 

 No matter how the page is altered, the caption and the image position will never 
alter. 

 

Using Relative Positioning for Layout 
 Relative positioning is similar to absolute positioning in that the Top and Left 

values can be set. 
 However, Relative Positioning allows the elements to be a part of the text 

stream, like static elements.  The location of the relative element does not have 
to be exact as they will appear on the page in the order that they appear within 
the HTML file. 
 
Note: That if an image is in relative positioning with text flowing around it, and 
if the Top or Left values are altered from the default value, the image will 
appear in the new location, but only white space will appear where the image 
used to be. 
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Using the Wrapping Text Style 
 Select the image on the page: 

 

 
 

 

 From the main menu, choose Format > Position to open the Position dialog 
box. 

 From the Positioning Style area, select None. 
 From the Wrapping Style area, select None, Left or Right to set how the text 

will wrap around the image: 
 

 
 

 Click OK: 
 

 
 
 

Using Dynamic Content 
 

Creating Page Transitions 
 Open the page that the transition will be applied to. 
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 From the main menu, choose Format > Page Transition to open the Page 
Transitions dialog box: 
 

 
 

 Select from the Event drop down menu if the effect will occur on Page Enter or 
Page Exit, or Site Enter or Site Exit: 
 

 
 

 Select from the Transition effect menu the specific transition wanted to occur 
to the page. 

 Select from the Duration field the number of seconds the effect will take to 
complete itself. 

 Click OK. 
 Two effects can be applied to a page, one on an entry, and another on an 

exit. 
 

Creating Collapsible Outlines 
 A collapsible outline is created around a list that is bulleted or numbered. 
 This allows you to create an outline that when clicking a topic heading, the 

information will appear under the heading, and then by clicking the heading 
again, the information will be removed. 

 You can create a nested list that has at least one sublevel within it: 
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 Click to place the insertion point within a main bullet list item. 
 From the main menu, choose Format > Bullets and Numbering to open the 

List Properties dialog box. 
 Select the Enable Collapsible Outlines checkbox: 

 

 
 

 This will allow you to close the list so only the main bullet headings are 
visible.  This will also treat the sub-lists as separate lists unto themselves. 

 When the page holding the list is opened in Internet Explorer 4 or 5 browsers, 
the entire list will be visible and the second-level headings under the main 
heading will disappear if the heading is selected: 
 

 
 

Setting Z-Ordering Layering 
 Z-ordering layering will allow you to stack images in a set order. 
 All of the layers are relative to the other, with layer 0 being the background 

image. 
 This layering effect works with Internet Explorer 4 and higher as well as 

Navigator 4 and higher. 
 Select the image to be layered: 
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 From the main menu, choose Format > Position to open the Position dialog 
box. 

 The Absolute or Relative icons must be selected in the Positioning style area 
to have access to the Z-Order drop-down menu. 

 Enter the required layer value in the Z-Order drop-down menu: 
 

 
 

 The bottom image is order 0, with each image being layered in the required 
order after that. 
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 The layers will be placed over each other matching the Z-Order placement: 
 

 
 

Collecting Elements 
 Graphics and text elements can be put inside an absolute position box so that 

they can be moved together on the page. 
 Type a line of text. 
 Insert an image next to the line of text: 

 

 
 

 Select both the image and the text: 
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 From the main menu, choose Format > Position to open the Position dialog 
box. 

 Select Absolute in the Position style area. 
 Click OK. 
 Both the image and the text will move when you select the position box with the 

4-arrow cursor to manually move the two: 
 

 
 
 

Review Questions 
 
How would you: 

 Use Frames? 
 Use a Frame Template? 
 Edit Framesets? 
 Create Custom Framesets? 
 Use Target Frames? 
 Create Custom Frameset Templates? 
 Place Pages into a Frameset? 
 Use Static Frames? 
 Remove a Frameset? 
 Use DHTML Layout Positioning? 
 Use Absolute Positioning for Layout? 
 Use Relative Positioning for Layout? 
 Use the Wrap Text Style? 
 Create Page Transitions? 
 Create Collapsible Outlines? 
 Set Z-Order Layering? 
 Collect Elements? 
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Forms 
 
When you have completed this learning module you will have seen how to: 

 Create a Form using the Form Page Wizard 
 Collect Form Content 
 Use the Saving Results Options 
 Create a Custom Form 
 Insert a Text Box field 
 Insert a Text Area field 
 Insert a File Upload field 
 Insert a Check Box field 
 Insert Option button fields 
 Insert a Group Box field 
 Insert a Drop-Down Box field 
 Insert Push Button field 
 Insert an Advanced Button field 
 Insert a Picture field 
 Insert a Form Label field 
 Set Form Properties 
 Create a Visitor Confirmation field 
 Use the Options for Discussion Form Handler dialog box 
 Use the Send to File option 
 Use the Send to Email option 
 Use the Send to Database option 
 Use the Send to Other option 
 
 

Creating a Form 
 

Creating a Form using the Form Page Wizard 
 The Form Page Wizard allows you to create fully functional forms, as well as 

customize it for specific cases. 
 From the main menu, choose File > New > Page or Web to open the New 

Page or Web task pane. 
 Select Page Templates in the New from template section to open the Page 

Templates dialog box. 
 Select the Form Page Wizard under the General tab to open the Form Page 

Wizard dialog box: 
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 Click Next to begin creating the form: 
 

 
 

 Click Add to move to the questions area of the wizard to select the type of input 
that will be added to the form to collect information. 
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 Only one question at a time can be inserted through the wizard: 
 

 
 

 Select the input type that the question will collect. 
 Once done, click Next to move to the next wizard window: 

 

 
 

 Select the specific information that will be collected with the first question on 
the form. 
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 Once done, click Next to move to the next wizard window: 
 

 
 

 Continue to use the Add button to add more questions and Input information as 
required. 

 Once all required questions have been selected, click the Next button to 
continue through the remainder of the form wizard: 
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 Select how the list of questions will be presented to the viewer, and if a table of 
contents should be provided on the page. 

 Once done, click Next to move to the next wizard window: 
 

 
 

 Select how the results from the form will be saved for later viewing, as well as 
name the results file. 
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 Once done, click Next to move to the final wizard window: 
 

 
 

 Click Finish to create the new Form page: 
 

 
 

 Save the page. 
 Select the Preview button at the bottom of the window to view how the page 

will look on a web browser: 
 

 
 

 Until the page is published on the web, the Submit Form and Reset Form 
buttons will not be functional. 

 

Collecting Form Content 
 If the save results to a web page option was selected in the OUTPUT 

OPTIONS window of the Form Wizard, look in the Folder list to locate it. 
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 A results page will be in the folder list, named formsrslt.htm. 
 When a viewer completes the form and clicks the Submit button, the results are 

automatically sent into this folder. 
 

To view the results accurately: 

 Open the folder in an application that will configure the storage format. 
 If the save results to a text file option was selected in the OUTPUT 

OPTIONS window of the Form Wizard, look in the Folder list to locate it. 
 A results page will be in the folder list, named formsrslt.txt. 
 Opening the file from the folder list will open it in an application that can read 

.txt files, typically Windows Notepad. 
 If the use custom CGI script option was selected in the OUTPUT OPTIONS 

window of the Form Wizard, the script will process the collected information 
and will store it however the script instructs it to. 

 

Using the Saving Results Options 
 The Save Results portion is the main handler of all form results.  It takes all 

information collected by a form and saves it to a file in a variety of available 
formats. 

 Right-click on a field within a form and from the pop-up menu that appears, 
select Form Properties to open the Form Properties dialog box: 
 

 
 

 

 Alter the options of where to store the form results, sending to a web field, a 
database, or other alternatives: 
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 Select the Send to option and click the Options button to open the Saving 
Results dialog box: 
 

 
 

 The File Results tab is the default tab, and will always be the first one seen on 
opening the dialog box. 

 The File name field allows you to name the file that the form results will be 
placed in. 

 The File format drop down menu allows you to choose the format for the file 
holding the form results. 

 Selecting the Include field names checkbox allows you to save the variable 
name and value of every field from the form in the results file. 

 Selecting the Latest results at end checkbox allows you to have the most 
recent results from the form placed at the end of that file, if the file is in the 
HTML format.  Files saved as text always have new information at the end of 
the file. 

 The Optional second file area allows you to set a different file to store the 
collected form information in.  This is a useful area, as some results may need 
to be stored in alternate formats to be able to work with them in alternate 
processing applications. 
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 Select the E-mail Results tab: 
 

 
 

 This tab allows you to set the email address that the results will be sent to, 
within an email, in a selected format. 

 The E-mail format drop down menu allows you to select the format for the 
results being sent via email.  Formatted text is the default setting. 

 Selecting the Include field names checkbox allows you to have the field 
names inserted into the results email. 

 The Subject line field allows you to create the appropriate subject line that will 
appear in the email message header. 

 The Reply-to line field allows you to set the form field value that will show in 
the email reply to line. 
 
Note: To manually enter alternate text, leave the Form field name checkbox 
deselected and type in the required text. 

 

 Select the Confirmation Page tab: 
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 Typically, a basic HTML confirmation page is sent to the viewer’s browser if this 
tab is left empty. 

 A different confirmation page can be selected to send to the viewer with the 
URL of confirmation page (optional) field. 

 The URL of validation failure (optional) field will be grayed out until at least 
one validation page is created for a specific form field.  A page can be sent to 
the viewer’s browser letting them know that the information they entered on the 
form was invalid. 

 Select the Saved Fields tab: 
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 The Saved Fields tab allows you to set specific form fields to be placed in the 
results file. 

 The Form fields to save area will list all the names of the fields on the form.  
Any fields selected in the list will be written to the results file according to the 
order that they appear in the list. 

 

Creating a Custom Form 
 It’s a good idea to create the needed form on paper before creating it within the 

application, giving you a clearer idea of what is required. 
 Open the page that the form will be created on. 
 Click to place an insertion point where the form will be created. 
 From the main menu, choose Insert > Form > Form. 
 This will place a new form area onto the page, with the Submit and Reset 

buttons.  The form boundaries can be seen as a line made of dashes: 
 

 
 

 If not already there, click to place the insertion point to the left of the Submit 
button. 

 Press the Enter key on the keyboard to create as many blank lines as required: 
 

 
 

 Insert and edit text and images to customize the form. 
 Use the Saving Results dialog box to understand the various fields that will be 

created on the custom form, and how to track the results. 
 
 

Inserting Form Fields 
 

Inserting Form Fields 
 The Insert Form command allows you to insert fields from buttons to drop-

down menus onto a page. 
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Inserting a Text Box field 
 A Textbox field allows one line of text and up to 999 characters. 
 Click to place the insertion point where the text box field will be located. 
 From the main menu, choose Insert > Form > Textbox to place a textbox 

field on the form: 
 

 
 

 Type anywhere beside the textbox to label the use of the box for the viewers. 
 Right-click on the textbox field and from the pop-up menu that appears, select 

Form Field Properties to open the Text Box Properties dialog box: 
 

 
 

 The Name field allows you to name the textbox itself.  This will not label the 
textbox on the form. 

 The Initial value field allows you to enter beginning text that will appear in the 
textbox. 

 The Width in Characters field allows you to set the full width of the textbox on 
the form. 

 Selecting Yes in the Password field options will cause anything entered into 
the textbox to be masked for security purposes: 
 

 
 

 Select the Validate button on the dialog box to open the Text Box Validation 
dialog box: 

SAMPLE



Page 64 – Microsoft FrontPage XP - Intermediate Level Manual 

FOR USE AT THE LICENSED SITE(S) ONLY 
 Cheltenham Courseware Ltd. 1995-2010 www.cheltenhamcourseware.com 

 

 
 

 The Required checkbox in the Data length area must be selected for the 
Display name field to be accessible. 

 The Display name field will be a specific name to be used within any error 
dialog boxes that will appear. 

 If the textbox is for a fax number, enter Fax Number into the Display name 
field, and when a user does not enter the information into the required field, an 
error message will appear saying Please enter a value for the Phone 
Number field. 

 Set the Data type drop down menu and other areas as required. 
 It is recommended to practice with these functions before finalizing them in a 

form. 
 Once done, click OK. 
 

Inserting a Text Area field 
 A Text Area field is scrollable, and allows multiple lines of text. 
 Click to place the insertion point where the text box field will be placed. 
 From the main menu, choose Insert > Form > Text Area to place a text area 

field on the form. 
 Right-click on the text area field and from the pop-up menu that appears, select 

Form Field Properties to open the TextArea Box Properties dialog box: 
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 Use the same methods as the Text Box Properties dialog box to alter the look 
and customize the text area field. 

 

Inserting a File Upload field 
 A File Upload field can be used in Internet Explorer 4 and higher, as well as 

Netscape 3 and higher. 
 This field allows for easy uploads from the user’s machine to your web site. 

 
Note: Before testing this example the site must be placed on a server before 
you can access the File Upload field area properties.  This will work only if the 
Web site is installed on a server that has the FrontPage Server Extensions 
installed. 
 

 From the main menu, choose Insert > Form > File Upload to insert a File 
Upload field: 
 

 
 

 Finish creating the pages and entire site as required. 
 Create a folder in the web where the received files will be placed. 
 Right-click on the folder icon in the folder list, and from the pop-up menu that 

appears, select Properties to open the Properties dialog box: SAMPLE
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 Deselect the Allow scripts to be run checkbox. 
 Select the Allow anonymous upload to this directory checkbox. 
 Once done, click OK. 
 Right-click on the form that the File Upload field is in, not on the field itself, 

and from the pop-up menu that appears, select Form Properties to open the 
Form Properties dialog box. 

 Select either the Send to file name or the Send to database options. 
 Click the Options button to open the Saving Results dialog box. 
 Select the File Upload tab: 
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 In the Destination field, enter the path for the upload folder created earlier. 
 Click OK to close the Saving Results dialog box. 
 Click OK to close the Form Properties dialog box. 
 

Inserting a Check Box field 
 A Checkbox field allows you to insert an element that allows the viewer to 

select specific and minimal choices. 
 Click to place the insertion point where the checkbox field will be placed. 
 From the main menu, choose Insert > Form > Checkbox to place a checkbox 

field on the form: 
 

 
 

 Right-click on the check box field and from the pop-up menu that appears, 
select Form Field Properties to open the Check Box Properties dialog box: 
 

 
 

 Alter the information as required, and once done, click OK. 
 

Inserting Option button fields 
 An Option button allows you to place an area on the form where the viewer is 

only allowed one selection from a variety of options. 
 Click to place the insertion point where the option button field will be located. 
 From the main menu, choose Insert > Form > Option Button to place an 

option button field on the form: 
 

 
 

 Right-click on the field and from the pop-up menu that appears, select Form 
Field Properties to open the Option Button Properties dialog box: 
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 Alter as required, and once done, click OK. 
 

Inserting a Group Box field 
 A Group Box field allows you to group various form elements within a visible 

box in the boundaries of the form.  It basically allows you to create a variety of 
sections on the form that relate to specific areas. 

 A group box field can only be used if the Page Compatibility options are set to 
Microsoft Internet Explorer only, versions 4.0 and higher. 

 From the main menu, choose Tools > Page Options to open the Page 
Options dialog box. 

 Select the Compatibility tab: 
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 Select the required browser from the Browsers drop down menu: 
 

 
 

 Select the required version from the Browser versions drop down menu: 
 

 
 

 Select the required server from the Servers drop down menu: 
 

 
 

 Once done, click OK. 
 Click to place the insertion point where the group box field will be placed. 
 From the main menu, choose Insert > Form > Group Box to place a group 

box field on the form: 
 

 
 

 Right-click on the field and from the pop-up menu that appears, select Group 
Box Properties to open the Group Box Properties dialog box: 
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 Alter the information as required, and once done, click OK. 
 

Inserting a Drop-Down Box field 
 A Drop-Down Box field allows you to give more selection options to the viewer. 
 Click to place the insertion point where the drop-down field will be located. 
 From the main menu, choose Insert > Form > Drop-Down Box to place a 

drop down box field on the form: 
 

 
 

 Right-click on the field and from the pop-up menu that appears, select Form 
Field Properties to open the Drop-Down Box Properties dialog box: 
 

 
 

 Alter the information as required, and once done, click OK. 
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Inserting Push Button field 
 A Push Button field allows you to either replace one of the buttons already 

created on the form, or create a new one for a separate area of the form. 
 Click to place the insertion point where the push button field will be positioned. 
 From the main menu, choose Insert > Form > Push Button to place a push 

button field on the form: 
 

 
 

 Right-click on the field and from the pop-up menu that appears, select Form 
Field Properties to open the Push Button Properties dialog box: 
 

 
 

 Alter the information as required, and once done, click OK. 
 

Inserting an Advanced Button field 
 An Advanced Button allows you to insert a slightly more descriptive version of 

the push button. 
 Click to place the insertion point where the advanced button field will be located. 
 From the main menu, choose Insert > Form > Advanced Button to place an 

advanced button field on the form: 
 

 
 

 Type directly onto the button to name it for the viewer. 
 Right-click on the field and from the pop-up menu that appears, select 

Advanced Button Properties to open the Advanced Button Properties 
dialog box: 
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 Alter the information as required, and once done, click OK. 
 

Inserting a Picture field 
 A Picture field is different from simply inserting an image onto a page. 
 The picture field does what a Submit button does; it’s just a fancy version of 

how the viewer can send the form. 
 Click to place the insertion point where the picture field will be located. 
 From the main menu, choose Insert > Form > Picture to place an picture field 

on the form: 
 

 
 

 Right-click on the field and from the pop-up menu that appears, select Picture 
Properties to open the Picture Properties dialog box: 
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 The Form Field tab is only to name the picture.  The field will not be labeled on 
the form, this is only for recording and file purposes. 

 Select the Appearance tab: 
 

 
 

 This tab allows you to set the Wrapping style of the field, Alignment, 
Spacing, Size, Width and Height. 

 Select the General tab: 
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 This tab allows you to view and/or edit the source of the image, as well as the 
type of image that is being placed. 

 Select the Video tab: 
 

 
 

 This tab allows you to set a video source for the Picture field. 
 Alter the information as required, and once done, click OK. 
 

Inserting a Form Label field 
 A Form Label field allows you to connect a line of text to another specific field. 
 If you try to add a Label field without doing the following steps, a warning 

dialog box will appear, telling you what to do: 
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 Create a Textbox field. 
 Type some identifying text beside the textbox field. 
 Select the field and the text. 
 From the main menu, choose Insert > Form > Label and the line of text will 

be connected to the textbox: 
 

 
 

Setting Form Properties 
 Right-click within the form boundaries, and from the pop-up menu that appears, 

select Form Properties to open the Form Properties dialog box: 
 

 
 

 Alter the properties as required. 
 Once done, click OK. 
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End of the preview sample 
 
 

 
 
This sample is approximately half of the full course.  Please see the table of contents at the 
beginning of this document to see the full list of topics covered in the full course. 
 
To purchase the rights to use the full training manuals at your training centre please see our 
web site at:  
 

http://www.cheltenhamcourseware.com 
 
A courseware licence allows you to make unlimited copies for use at your training centre. 
 

 
 
In addit ion you get HTML formatted versions of each 
course, included w ith our printable coursew are. 
 
Invest in a complete Computer Courseware Library, 
including Windows 7 & Office 2010 
The most cost effective courseware solution for your IT 
training needs. Get ALL our courses, and all new  courses 
released w ithin 12 months. 
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